计算两个大整数的和



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110 一开始我以为用long long型的数字就可以满足条件了,但是我编译器不通过,我就试了哈提交上去,但是答案显示wa . 虽然对于很大的数据不对,但是对于long型以内的数据还是满足的,所以还是先把代码贴上来,后面贴满足真正意义上的大数据的代码
#include <stdio.h>


long len(long num1,long num2)
{
	long sum = 0 , sum_tmp = 1 , sum_two = 0;
	while(num1 != 0 && num2 != 0)
		{
			sum_two = (num1%10) + (num2%10);
			sum += sum_tmp*sum_two;
			sum_tmp *= 10;
			num1 /= 10;
			num2 /= 10;
		}
	if(num1 != 0)
	{
		while(num1 != 0)
		{
			sum_two = num1%10;
			sum += sum_tmp*sum_two;
			sum_tmp *= 10;
			num1 /= 10;
		}
		
	}
	else if(num2 != 0)
	{
		while(num2 != 0)
		{
			sum_two = num2%10;
			sum += sum_tmp*sum_two;
			sum_tmp *= 10;
			num2 /= 10;
		}
		
	}
	return sum;
}

int main()
{
	long n , a , b ,sum = 0;
	int i ;
	scanf("%d",&n);
	for(i = 0 ; i < n ; i ++)
	{
		scanf("%lld%lld",&a,&b);
		
		sum = len(a,b);

		printf("case %d:\n",i+1);
		if(i != n-1)
		{	
			printf("%lld+%lld=%lld\n\n",a,b,sum);
		}
		else if(i == n-1)
			printf("%lld+%lld=%lld\n",a,b,sum);
	}
	return 0 ;
}

下面贴上真正意义上符合大数据加法的代码:

#include<stdio.h>
#include<string.h>

void reverse( char *s )        /*将字符串逆置*/
{
    int length;
    int i = 0;
    char temp;
    length = strlen( s );
    while( i < length - i - 1 )
    {
        temp = s[i];
        s[i] = s[length - i - 1];
        s[length - i - 1] = temp;
        i++;
    }
}

void AddBigNum( char* s1, char* s2, char* result )
{
    int len1 = strlen( s1 );
    int len2 = strlen( s2 );
    int acc = 0, temp, i;        /*acc为进位标记*/
    if( s1 == NULL || s2 == NULL || result == NULL )
    {
        return;
    }
    reverse( s1 );
    reverse( s2 );
    for( i = 0; i < len1 && i < len2; i++ )
    {
        temp = s1[i] - '0' + s2[i] - '0' + acc;        /*计算每位的实际和*/
        result[i] = temp % 10 + '0';        /*通过求余数来确定每位的最终值*/
        if( temp >= 10 )        /*通过这个if..else..条件来判断是否有进位,并设置进位值*/
            acc = 1;
        else
            acc = 0;
    }
    if( i < len1 )        /*两个加数位数不同*/
    {
        for( ; i < len1; i++ )
        {
            temp = s1[i] - '0' + acc;        /*依旧要考虑进位,比如9999 + 1的情况*/
            result[i] = temp % 10 + '0';
            if( temp >= 10 )        
                acc = 1;
            else
                acc = 0;
        }
    }
    if( i < len2 )
    {
        for( ; i < len2; i++ )
        {
            temp = s2[i] - '0' + acc;
            result[i] = temp % 10 + '0';
            if( temp >= 10 )
                acc = 1;
            else
                acc = 0;
        }
    }

    if( acc == 1 )        /*考虑如:123 + 911 = 1034的情况,如果不增加这个条件会得到结果为034,进位被舍弃*/

        result[i++] = '1';

    result[i] = '\0';
    reverse( result );
}

void main()
{
    char s1[1000] = {0};
    char s2[1000] = {0};
	char result[1002];
	int n,i;
	scanf("%d",&n);
	for(i = 0 ; i < n ; i ++)
	{
		scanf("%s%s",s1,s2);
		printf("case %d:\n",i+1);
		printf("%s + %s = ",s1,s2);
		AddBigNum( s1, s2, result );
		if(i != n-1)
		{
			printf( "%s\n\n", result );
		}
		else if(i == n-1)
			printf( "%s\n", result );
	}

}
结果还是wa...好难过



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值