Bone Collector
Total Submission(s): 23016 Accepted Submission(s): 9334
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
Code:
#include<stdio.h>
int w[1005],val[1005],f[1005];
int main()
{
int t,n,i,j,v;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&v);
for(i=0;i<=1001;i++) f[i] = 0; //求最大价值初始化为0,装满则初始化为负无穷
for(i=1;i<=n;i++) scanf("%d",&val[i]);
for(i=1;i<=n;i++) scanf("%d",&w[i]);
for(i=1;i<=n;i++){
for(j=v;j>=0;j--){
int tmp;
if(j-w[i] >= 0) tmp = val[i] + f[j-w[i]]; //防止越界出错
else tmp = f[j];
f[j] = f[j] > tmp ? f[j] : tmp;
}
}
printf("%d\n",f[v]);
}
return 0;
}