HDU1247 Hat’s Words 解题报告--字典树

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5699    Accepted Submission(s): 2120


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

Author
戴帽子的
 

Recommend

Ignatius.L

#include<iostream>
using namespace std;
#include<cstring>
struct node
{
    int flag;//树尾部的标记
    node *next[26];
    node()
    {
        flag=0;
        memset(next,0,sizeof(next));
    }
};
node *root=NULL;
void build(char *s) //建树
{
    node *p=root; 
    int len=strlen(s);
    int i;
    for(i=0;i<len;i++) 
    {   
        
        if(p->next[s[i]-'a']==NULL)
        {
            p->next[s[i]-'a']=new node; 
        }
        p=p->next[s[i]-'a'];
    }
    p->flag=1;
}
int find(char *s) 
{
    node *p=root;
    int len=strlen(s);
    int i;
    for(i=0;i<len;i++)
    {
        if(p->next[s[i]-'a']==NULL)
        {
            return 0;
        }
        p=p->next[s[i]-'a'];
    }
    if(p->flag==0)//判断是否到达字典最后一个字母避免只有前部分相同
        return 0;
    else
        return 1;
}
int main()
{
    root=new node;
    char str[50001][20];
    int i,j,k,l;
    int c=0;
    while(~scanf("%s",str[c]))
    {
        build(str[c]);//建树
        c++;
    }
    for(i=0;i<c;i++)
    {
        int len=strlen(str[i]);
        int n=0;
        char a[20],b[20];
        int aa,bb;
        for(j=0;j<len;j++)//将字符串分段检索
        {
            n++;
            aa=0;bb=0;
            for(k=0;k<len;k++)
            {
                if(k<n) a[aa++]=str[i][k];
                else
                    b[bb++]=str[i][k];
            }
            a[aa]=0;b[bb]=0;//一个字符分成ab段检测ab是否都可检索到
            if(find(a)&&find(b))
			{
				printf("%s\n",str[i]);
				break;//一旦找到,则跳出避免重复输出
			}
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值