hdu1698-Just a Hook

线段树入门题

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17609    Accepted Submission(s): 8809


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 


#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int N,size;
struct Node{//树节点 
	int kind;
	int cl,cr;
	Node *l,*r;
}tree[400005];
void init(Node* root,int tcl,int tcr){//初始化 
	root->cl=tcl;
	root->cr=tcr;
	root->kind=1;
	if(tcl==tcr){
		root->l=NULL;
		root->r=NULL;
		return ;
	}
	int mid=(tcl+tcr)>>1;
	root->l=tree+size++;
	root->r=tree+size++;
	init(root->l,tcl,mid);//递归构建左右子树 
	init(root->r,mid+1,tcr);
}
void insert(Node* root,int l,int r,int kind){
//	cout<<root->cl<<" "<<root->cr<<" "<<l<<" "<<r<<endl; 
	if(l==root->cl&&r==root->cr||root->kind==kind){//区间相同 
		root->kind=kind;
		return ;
	}
	if(root->kind!=-1){//更新左右子节点 
		root->l->kind=root->kind;
		root->r->kind=root->kind;
	}
	root->kind=-1;//本区间kind不一致 
	int mid=(root->cl+root->cr)>>1;
	if(mid<r&&mid>=l) {//下滤,特别要注意边界,小于和小于等于,大于和大于等于等情况
		insert(root->l,l,mid,kind);
		insert(root->r,mid+1,r,kind);
	}
	else if(mid>=r){
		insert(root->l,l,r,kind);
	}
	else {
		insert(root->r,l,r,kind);
	}
	if(root->l->kind!=-1&&root->r->kind==root->l->kind){//更新本节点 
		root->kind=root->l->kind;
	}
}
		
int ans(Node* root){
//	cout<<root->cl<<" "<<root->cr<<" "<<root->kind<<endl;
	if(root->kind!=-1) return root->kind*(root->cr-root->cl+1);//本区间kind一致 
	return ans(root->l)+ans(root->r);
}
int main(){
	int i,j,k,m,n,T,kase,Q,l,r,kind;
	ios::sync_with_stdio(false);
	cin>>T;
	for(kase=1;kase<=T;kase++){
		cin>>N;
		size=1;
		init(tree,1,N);
		cin>>Q;
		for(i=0;i<Q;i++){
			cin>>l>>r>>kind;
			insert(tree,l,r,kind);
		}
		cout<<"Case "<<kase<<": The total value of the hook is ";
		cout<<(ans(tree))<<"."<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值