hdu 1024 Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17132    Accepted Submission(s): 5624


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 


#include<iostream>
#include<algorithm>
#include<cstring>
#define MAX(x,y)  ((x)>(y)?(x):(y))
using namespace std;
long long  arr[1000005];//输入数据 
long long dp[1000005];//表示前i个数取j段且取arr[i]的最优解 (滚动数组) 
long long sum[1000005]; //前i个的和 
long long  maxn[2][1000005];//maxn[cur][i]表示前i个数取j段的最优解,maxn[pre][i]表示前i个取j-1段的最优解(滚动数组) 
int N,M;
int main(){
	int i,j,k,m,n; 
	ios::sync_with_stdio(false);
	while(cin>>M>>N){
//		memset(maxn,0,sizeof(maxn)); 
		for(i=1;i<=N;i++){
			cin>>arr[i];
			sum[i]=sum[i-1]+arr[i];
			maxn[0][i]=maxn[1][i]=0;
//			dp[i]=arr[i];
		}
		int cur=1,pre=0;
		for(j=1;j<=M;j++){
			for(i=j;i<=N;i++){
				if(i==j){
					dp[i]=sum[i];
					maxn[cur][i]=sum[i];
				}
				else {
					maxn[cur][i]=maxn[cur][i-1];
					dp[i]=MAX(dp[i-1],maxn[pre][i-1])+arr[i];//最优化策略:前i个选j段的最优解取下面两个值的较大者,①前i-1个取
															//j个且取arr[i-1]加上arr[i] ②前i-1个取j-1个的的最优解加上arr[i] 
//					dp[i]=dp[i-1]+arr[i];
//					if(j>1)dp[i]=MAX(dp[i],maxn[pre][i-1]+arr[i]);
					if(dp[i]>maxn[cur][i])maxn[cur][i]=dp[i];//更新maxn[cur][i] 
				}
				
			}
			swap(cur,pre);//滚动 
		}/*
		int ans=dp[M];
		for(i=M;i<=N;i++){
			ans=MAX(ans,dp[i]);
		}
		cout<<ans<<endl;*/
		cout<<maxn[M&1][N]<<endl;
	}
}
			
				



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值