fzuProblem 1901 Period II

Problem 1901 Period II

Accept: 107    Submit: 297
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

For each prefix with length P of a given string S,if

S[i]=S[i+P] for i in [0..SIZE(S)-p-1],

then the prefix is a “period” of S. We want to all the periodic prefixs.

 Input

Input contains multiple cases.

The first line contains an integer T representing the number of cases. Then following T cases.

Each test case contains a string S (1 <= SIZE(S) <= 1000000),represents the title.S consists of lowercase ,uppercase letter.

 Output

For each test case, first output one line containing "Case #x: y", where x is the case number (starting from 1) and y is the number of periodic prefixs.Then output the lengths of the periodic prefixs in ascending order.

 Sample Input

4oooacmacmacmacmacmafzufzufzufstostootssto

 Sample Output

Case #1: 3
1 2 3
Case #2: 6
3 6 9 12 15 16
Case #3: 4
3 6 9 10
Case #4: 2
9 12



#include <iostream>
#include <cstring>
using namespace std;
const int MAXN = 1000005;
int next[MAXN],m,cnt;
char pattern[MAXN];
int queue[MAXN],front,rear;

void get_next(){
    int i=0, j=-1;
    next[i]=j;
    while(i<m){
        if(j==-1 || pattern[i]==pattern[j]){
            i++; j++;
            next[i]=j;
        }else j=next[j];
    }
}

int main()
{
    int n;
    cin>>n;
    for(int i=1; i<=n; i++){
        cin>>pattern;
        m=strlen(pattern);
        get_next();
        front=0; rear=0; cnt=1;
        int t=m;
        while(next[t]) {queue[rear++]=next[t]; cnt++; t=next[t];}
        cout<<"Case #"<<i<<": "<<cnt<<endl;
        while(front<rear){
            cout<<m-queue[front++]<<" ";
        }
        cout<<m<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值