Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
Sample Output
1
0
2
998
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
typedef long long lld;
int road[1001];
int find(int x)
{
return x==road[ x ] ? x : road[x]=find ( road [ x ]);
}
void merge(int x,int y)
{
int fx,fy;
fx=find(x);
fy=find(y);
if(fx==fy) return;
if(fx<fy)
road[fy]=fx;
else road[fx]=fy;
}
int main() {
int n,m;
while(scanf("%d%d",&m,&n),m)
{
int a,b;
for(int i=1;i<=m;i++)
road[i]=i;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a,&b);
merge(a,b);
}
int count=0;
for(int j=1;j<=m;j++)
if(road[j]==j)
count++;
printf("%d\n",count-1);
}
return 0;
}
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
typedef long long lld;
int d[1001],groups; //用groups表示集合数目
int find(int x)
{
return x==d[x]?x:d[x]=find(d[x]);
}
void merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx==fy) return;
groups--;
if(fx<fy)
d[fy]=fx; // 合并两个集合
else
d[fx]=fy; //合并到 以编号较小的集合
}
int main() {
int n,m;
while(scanf("%d%d",&n,&m),n)
{
int a,b;
groups=n;
for(int i=1;i<=n;i++) //初始化每个点是一个集合
d[i]=i;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
merge(a,b);
}
printf("%d\n",groups-1);
}
return 0;
}