POJ 3687 Labeling Balls-拓扑排序

题目:

Description


Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:


No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?


Input


The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.


Output


For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.


Sample Input


5


4 0


4 1
1 1


4 2
1 2
2 1


4 1
2 1


4 1
3 2
Sample Output


1 2 3 4
-1
-1
2 1 3 4
1 3 2 4


方法:拓扑排序



代码:

#include<iostream>
using namespace std;
int adjMat[201][201] = { 0 };//0表示两者没有关系,下标从1开始,也是球的标号
int finishOrder[201] = { 0 };//节点完成搜索的顺序
int beginOrder[201] = { 0 }; //节点开始搜索的顺序
int num, N, M, t1, t2;               //N(1 ≤ N ≤ 200):N个球(N个节点) and M(0 ≤ M ≤ 40000)(M个限制关系)

int dfs(int label_n) //标号n
{
	if (beginOrder[label_n] > 0) //如果该节点已经被开始搜索,则说明出现了环路
		return -1;
	beginOrder[label_n] = ++t1;
	int j = 0;
	for (j = 1; j <= N; ++j)
	{
		if (adjMat[label_n][j] == 1 && finishOrder[j] == 0)
		{
			if (dfs(j) == -1)
				return -1;
		}
	}
	if (j - 1 == N)
		finishOrder[label_n] = ++t2;
	return 0;
}

int topoSort()
{
	for (int i = 1; i <= N; ++i)
		if (finishOrder[i] == 0)
			if (dfs(i) == -1)
				return -1;
	return 0;
}

void main()
{
	int i, j;
	cin >> num;
	while (num--)
	{
		t1 = 0;
		t2 = 0;
		cin >> N >> M;
		for (int m = 0; m < M; m++)
		{
			cin >> i >> j;    //i标号的重量小于j标号的重量,通常i>j
			adjMat[j][i] = 1; //反过来就是,j标号的重量大于i标号的重量
		}
		if (topoSort() == -1)
			cout << "出现了环路,无解!";
		else
			for (int k = 1; k <= N; ++k)
				cout << finishOrder[k] << ' ';
		cout << endl;
		memset(adjMat, 0, sizeof(adjMat));
		memset(finishOrder, 0, 4 * (N + 1));
		memset(beginOrder, 0, 4 * (N + 1));
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值