hdu1147:pick up sticks



Pick-up sticks

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2044    Accepted Submission(s): 769


Problem Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
 

Input
Input consists of a number of cases. The data for each case start with 1 ≤ n ≤ 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
 

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.
The picture to the right below illustrates the first case from input.
 

Sample Input
  
  
5 1 1 4 2 2 3 3 1 1 -2.0 8 4 1 4 8 2 3 3 6 -2.0 3 0 0 1 1 1 0 2 1 2 0 3 1 0
 

Sample Output
  
  
Top sticks: 2, 4, 5. Top sticks: 1, 2, 3.
 
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
using namespace std;

const int MAXN = 100001;
bool top[MAXN];
struct Point{
    double x, y;
};

struct Line{
    Point st, ed;
}line[MAXN];
double max(double a, double b){
    return a > b ? a : b;
}
double min(double a, double b){
    return a < b ? a : b;
}
double dist(Point &a1, Point &a2){
    return sqrt((a1.x - a2.x)*(a1.x - a2.x) + (a1.y - a2.y)*(a1.y - a2.y));
}

bool kpc(Line l1, Line l2){
    return min(l1.st.x, l1.ed.x) <= max(l2.st.x, l2.ed.x) && min(l1.st.y, l1.ed.y) <= max(l2.st.y, l2.ed.y)
        && min(l2.st.x, l2.ed.x) <= max(l1.st.x, l1.ed.x) && min(l2.st.y, l2.ed.y) <= max(l1.st.y, l1.ed.y);
}

bool kual(Line l1, Line l2){
    Point A, B;
    Point C, D;
    bool flag1, flag2;
    flag1 = flag2 = false;
    A = l1.st;
    B = l1.ed;
    C = l2.st;
    D = l2.ed;
    double t1 = (C.x - A.x)*(B.y - A.y) - (C.y - A.y)*(B.x - A.x);
    double t2 = (D.x - A.x)*(B.y - A.y) - (D.y - A.y)*(B.x - A.x);
    if (t1*t2 <= 0)
    {
        flag1 = true;
    }
    t1 = (B.x - C.x)*(D.y - C.y) - (B.y - C.y)*(D.x - C.x);
    t2 = (A.x - C.x)*(D.y - C.y) - (A.y - C.y)*(D.x - C.x);
    if (t1*t2 <= 0){
        flag2 = true;
    }
    if (flag1&&flag2){
        return true;
    }
    return false;
}
int main(){
    int n;
    int i, j;
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
    while (cin >> n, n){
        for (i = 0; i < n; i++){
            cin >> line[i].st.x >> line[i].st.y;
            cin >> line[i].ed.x >> line[i].ed.y;
            top[i] = true;
        }
	//注意到
/*
	效率低若n>1000则会超时
	for(i=0;i<n;i++){
	    for(j=0;j<i;j++){
		if(top[j]){
		    if(kpc(line[i],line[j]){
                    	if(kual(line[i],line[j]){
			     top[j]=false;
			     
			}
                    }
                }
	    }
	}
*/

        for (i = 0; i < n; i++){
            for (j = i+1; j < n; j++){
                if (kpc(line[i], line[j])){
                    if (kual(line[i], line[j])){
                        top[i] = false;
                        break;
                    }
                }
            }
        }
        bool flag = false;
        j = -1;
        cout << "Top sticks: ";
        for (i = 0; i < n; i++){
            if (top[i] && flag){
                cout << j + 1 << ", ";
                j = i;
            }
            else if (top[i]){
                j = i;
                flag = true;
            }
        }
        cout << j + 1 << "." << endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值