poj3442 Party at Hali-Bula 简单树形dp

http://poj.org/problem?id=3342

Party at Hali-Bula
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5384 Accepted: 1910

Description

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the followingn-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No

Source


和上一个题基本一样,多了一个要求。判断最后的最大值是否唯一。我们用个f数组记录下,值为一表示唯一
对于dp[i][1]由dp[j][0]转移来,当f[j][0]有一个为0时那么f[i][1]就得是0
对于dp[i][0]当dp[j][0]等于dp[j][1]时肯定f[i][0]为0,当dp[j][0]>dp[j][1]就看f[j][0]是否为0,小于就看f[j][1]。
开始的字符串用map处理下简单方便
代码:
/**
 * @author neko01
 */
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=205;
map<string,int>mp;
vector<int>g[N];
int dp[N][2];
int f[N][2];  //为1表示以u为根的子树选和不选u时唯一
void dfs(int u)
{
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        dfs(v);
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        if(dp[v][0]==dp[v][1]) f[u][0]=0;
        else if(dp[v][0]>dp[v][0]&&f[v][0]==0) f[u][0]=0;
        else if(dp[v][0]<dp[v][1]&&f[v][1]==0) f[u][0]=0;
        dp[u][1]+=dp[v][0];
        if(f[v][0]==0) f[u][1]=0;
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<=n;i++)
        {
            g[i].clear();
            dp[i][0]=0;
            dp[i][1]=1;
            f[i][0]=f[i][1]=1;
        }
        mp.clear();
        int tot=0;
        string s1,s2;
        cin>>s1;
        mp[s1]=++tot;
        for(int i=1;i<n;i++)
        {
            cin>>s1;
            if(mp[s1]==0)
                mp[s1]=++tot;
            cin>>s2;
            if(mp[s2]==0)
                mp[s2]=++tot;
            g[mp[s2]].pb(mp[s1]);
        }
        dfs(1);
        if(dp[1][0]>dp[1][1])
        {
            if(f[1][0]==1) printf("%d Yes\n",dp[1][0]);
            else printf("%d No\n",dp[1][0]);
        }
        else if(dp[1][0]==dp[1][1])
            printf("%d No\n",dp[1][0]);
        else
        {
            if(f[1][1]==1) printf("%d Yes\n",dp[1][1]);
            else printf("%d No\n",dp[1][1]);
        }
    }
    return 0;
}

结尾对舍友早早关灯吐下槽,习惯晚睡加班的我233,虽然习惯不好。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值