poj1164 The Castle 水搜索

0 篇文章 0 订阅

http://poj.org/problem?id=1164

The Castle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6382 Accepted: 3610

Description

     1   2   3   4   5   6   7  

   #############################

 1 #   |   #   |   #   |   |   #

   #####---#####---#---#####---#

 2 #   #   |   #   #   #   #   #

   #---#####---#####---#####---#

 3 #   |   |   #   #   #   #   #

   #---#########---#####---#---#

 4 #   #   |   |   |   |   #   #

   #############################

(Figure 1)



#  = Wall   

|  = No wall

-  = No wall

Figure 1 shows the map of a castle.Write a program that calculates 
1. how many rooms the castle has 
2. how big the largest room is 
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

Input

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

Source


水题。就是m*n的房子每个点四周可能有墙,1 2 4 8分别代表哪四个方向有墙。告诉每个格子四周之和,问连通块个数和最大连通快个数。
分析:首先由每个格子的数可以唯一确定这个点四个方向是否有墙(很有意思由2的n次方可以唯一组成2^(n+1)以下所有数),具体的判断方法是通过位运算!!这样我们就dfs或者bfs找连通块了。。
/**
 * @author neko01
 */
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=55;
int a[N][N];
bool vis[N][N];
int ans,num;
int n,m;
int dir[4][2]={0,-1,-1,0,0,1,1,0};
bool immap(int x,int y)
{
    return x>=0&&y>=0&&x<n&&y<m;
}
void bfs(int sx,int sy)
{
    vis[sx][sy]=true;
    queue<pp>q;
    q.push(mp(sx,sy));
    int tmp=0;
    while(!q.empty())
    {
        pp cur=q.front();
        q.pop();
        int x=cur.first;
        int y=cur.second;
        tmp++;
        for(int i=0;i<4;i++)
        {
            int xx=x+dir[i][0];
            int yy=y+dir[i][1];
            if(!((1<<i)&a[x][y])&&immap(xx,yy)&&!vis[xx][yy])
            {
                q.push(mp(xx,yy));
                vis[xx][yy]=true;
            }
        }
    }
    if(tmp>ans) ans=tmp;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                scanf("%d",&a[i][j]);
        clr(vis);
        ans=num=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(!vis[i][j])
                {
                    bfs(i,j);
                    num++;
                }
            }
        printf("%d\n%d\n",num,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值