hdu5074 Hatsune Miku 2014鞍山现场赛E题 水dp

这篇博客详细介绍了HDU 5074题目'Hatsune Miku 2014鞍山现场赛E题'的解决方案,重点探讨了一个涉及动态规划(dp)的水问题。通过分析题目,博主分享了如何运用dp技巧来求解这一竞赛题目,并可能涉及Hatsune Miku这一虚拟歌手的相关背景。
摘要由CSDN通过智能技术生成

http://acm.hdu.edu.cn/showproblem.php?pid=5074

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 325    Accepted Submission(s): 243


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

Source

题意:n个位置放乐符,总共m种乐符,给一个m*m的的矩阵表示(i,j)表示j在i后面一个位置产生的value,有的位置已经放了给定乐符,问所产生的最大value是多少。
题解:水dp。dp[i][j]表示第i个位置放第j种乐符所产生的value,就是转移的时候要注意下各种条件,约等于一个模拟题了。。。
/**
 * @author neko01
 */
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
int a[55][55];
int dp[105][55];
int b[105];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&a[i][j]);
        b[0]=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        clr(dp);
        for(int i=2;i<=n;i++)
        {
            if(b[i]!=-1)
            {
                if(b[i-1]==-1)
                {
                    for(int j=1;j<=m;j++)
                    {
                        dp[i][b[i]]=max(dp[i-1][j]+a[j][b[i]],dp[i][b[i]]);
                    }
                }
                else
                    dp[i][b[i]]=dp[i-1][b[i-1]]+a[b[i-1]][b[i]];
            }
            else
            {
                if(b[i-1]==-1)
                {
                    for(int j=1;j<=m;j++)
                        for(int k=1;k<=m;k++)
                            dp[i][j]=max(dp[i][j],dp[i-1][k]+a[k][j]);
                }
                else
                    for(int j=1;j<=m;j++)
                        dp[i][j]=max(dp[i][j],dp[i-1][b[i-1]]+a[b[i-1]][j]);
            }
        }
        int ans=0;
        if(b[n]!=-1) ans=dp[n][b[n]];
        else
        {
            ans=dp[n][1];
            for(int i=2;i<=m;i++)
                ans=max(ans,dp[n][i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值