[ACM] HDU 5074 Hatsune Miku (简单DP)

286 篇文章 140 订阅
49 篇文章 0 订阅

Hatsune Miku



Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

Source


解题思路:

题意为有m种音符,编号1到m,我们要用这m种音符来创造一首带有n个音符的曲子(当然,一种音符可以用多次),假设有两个连续的音符 i ,j ,那么定义score(i,j)为这两个音符的得分,题目中预先给出所有的score(i,j)   1<=i,j<=m, 那么我们创造出的n个音符的曲子的得分为  score( note[i] , note[i+1] ) + score (note[i+1] ,note[i+2) +......score(note[n-1],note[n]) , i从1开始。 note [i] 代表n个音符的曲子中第i个音符是第几种音符, 1<=note[i]<=m, 比如 note[i]=3,就表示n个音符中第i个位置用的是第3种音符(一共有m种),预先给出 这n个音符,note[1] 到note[n] ,其中note[ i] 或者等于-1 ,或者 大于等于1小于等于m,对于后者,该位置的音符不能改变,对于前者,该位置可以换成任意的音符j(1<=j<=m), 问 这n个音符所获得的最大得分是多少。


虽然是简单Dp,但还是Dp题做的少,不敏感,一开始还用暴搜来做了。。

定义dp [i ][j],为前i个音符且第i个音符为第j种音符所获得的最大得分。

分情况讨论:

当note[i] >0 (i>=2)时:

当note[i-1]>0时: dp[i][note[i]]=dp[i-1][note[i-1]]+score[note[i-1]][note[i]];

当note[i-1]<0时: dp[i][note[i]]=max(dp[i][note[i]],dp[i-1][j]+score[j][note[i]]);   1<=j<=m,  枚举第i-1个音符是第几种音符


当note[i]<0    (i>=2)时:

当note[i-1]>0时:dp[i][j]=max(dp[i][j],dp[i-1][note[i-1]]+score[note[i-1]][j]);       1<=j<=m,     枚举第i个音符是第几种音符

当note[i-1]<0时:dp[i][j]=max(dp[i][j],dp[i-1][k]+score[k][j]);     1<=j,k<=m, 枚举第i个音符和第i-1个音符是第几种音符

代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int n,m;
int score[52][52];
int dp[102][52];//dp[i][j]表示为前i个音符,以第j种音符结尾所获得的最大分数
int note[102];
int ans;

void DP()
{
    memset(dp,0,sizeof(dp));
    for(int i=2;i<=n;i++)
    {
        if(note[i]>0)
        {
            if(note[i-1]>0)
                dp[i][note[i]]=dp[i-1][note[i-1]]+score[note[i-1]][note[i]];
            else
            {
                for(int j=1;j<=m;j++)
                    dp[i][note[i]]=max(dp[i][note[i]],dp[i-1][j]+score[j][note[i]]);
            }
        }
        else
        {
            if(note[i-1]>0)
            {
                for(int j=1;j<=m;j++)
                    dp[i][j]=max(dp[i][j],dp[i-1][note[i-1]]+score[note[i-1]][j]);
            }
            else
            {
                for(int j=1;j<=m;j++)
                    for(int k=1;k<=m;k++)
                    dp[i][j]=max(dp[i][j],dp[i-1][k]+score[k][j]);
            }
        }
    }
    ans=-1;
    if(note[n]>0)
        ans=dp[n][note[n]];
    else
    {
        for(int j=1;j<=m;j++)
        {
            if(ans<dp[n][j])
                ans=dp[n][j];
        }
    }
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=m;j++)
            cin>>score[i][j];
        for(int i=1;i<=n;i++)
            cin>>note[i];
        DP();
        cout<<ans<<endl;
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值