POJ 一 3032 Card Trick

Card Trick
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3549 Accepted: 2540

Description

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integern.

Output

For each test case, output a line with the correct permutation of the values 1 ton, space separated. The first number showing the top card of the pack, etc…

Sample Input

2
4
5

Sample Output

2 1 4 3
3 1 4 5 2

Source


为了给好基友补作业。。好基友睡了我还在写。。。我自己都感动哭了。。。 大哭 大哭 大哭

题意是翻纸牌,第n次刚好翻出第n牌。
第一次先将最上面一张牌放到最下面,翻出当前最上面一张牌。
第二次先将最上面一张牌放到最下面,再将最上面一张牌放到最下面,再翻出当前最上面一张牌。
多次翻牌按照上述规律。。。

之前一直没有理解题意。。。不明白例如只剩两张牌的时候怎么翻三次。。后来明白要一次一次翻。。。
按照题述步骤反着模拟即可,注意循环次数的控制。
代码如下:
#include <stdio.h>
int main(void)
{
    int n,m,i,j;
    
    scanf("%d",&n);
    while(n--)
    {
     scanf("%d",&m);
     int a[14]={0};
     a[m-1]=m;
     for(i=m-1;i>0;i--)//用i来表示添加大小为i的牌 
     {
      a[i-1]=i;
      int temp;
      int k,t;
      for(j=0;j<i;j++)//用j来控制反着翻牌j次 
      {
       k=m-i;
       temp=a[m-1];
       for(t=0;t<k;t++)
       /*在这里用t来控制依次翻牌,如a[1],a[2],a[3],a[4]交换
       就需a[2]=a[3],a[3]=a[4],而a[1],a[2],a[3],a[4],a[5]交换
       就需a[2]=a[3],a[3]=a[4],a[4]=a[5]*/ 
        a[m-t-1]=a[m-t-2];
       a[i-1]=temp;
      }
     }
     for(i=0;i<m;i++)
     {
      if(i==m-1)
       printf("%d\n",a[i]);
      else
       printf("%d ",a[i]);
     }          
    }
    return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值