hdu 1018 Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24081    Accepted Submission(s): 10926


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1017  1016  1071  1019  1021 
输入一个n,求n阶乘结果有多少位
室友胜哥考我的一道题,我都没怎么想就百度了。。。
这个臭毛病一定要改,遇到题多思考,不要上手就百度
有两种方法
1、用log的性质log(n!) = log1 + log2 + ... + logn; log(n!)即n!的位数
2、用斯特林公式;
当然斯特林公式也要用到log思想来求位数

需要注意的是log的使用,大概hdu上的c++版本不够,我的编译器可以通过,但是交题后显示CE
改正后的代码如下:
#include <map>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define esp 1e-9
#define MAXN 10010
#define ll long long
#define INF 0x7FFFFFFF
#define BUG system("pause")
#define SW(a,b) a^=b;b^=a;a^=b;
#define Pi 3.1415926
using namespace std;
int main(void){
	int n;
	while(cin >> n){
		while(n--){
			int a;
			cin >> a;
			double sum = 0;
			for(int i=1; i<=a; ++i){
				sum += (log(i*1.0)/log(10.0));
			} 
//			cout << (int)sum+1 << endl;
			cout << (int)(0.5*(log(2.0*Pi*a)/log(10.0))+a*1.0*(log(a*1.0)-1.0)/log(10.0))+1 << endl;
		}
	} 

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值