UVa 12097 - Pie

Problem C - Pie

Time limit: 1 second

 My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

  • One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume  V  such that me and my friends can all get a pie piece of size  V . The answer should be given as a floating point number with an absolute error of at most 10 -3 .

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655
The 2006 ACM Northwestern European Programming Contest

输入第一行为T,代表T个样例
每个样例包含n, f以及n个半径
求在每人分一块披萨且面积均相同时把披萨分成f+1块对应的每块最大面积
二分法解题
隔一段时间没做二分就又忘了。。。
设定L表示左边界,R表示右边界,M表示中间值
只需每次更新R,L直到每块披萨的面积为M时恰可以分f+1块
代码如下:
#include <map>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define esp 1e-9
#define MAXN 10010
#define ll long long
#define INF 0x7FFFFFFF
#define BUG system("pause")
#define SW(a,b) a^=b;b^=a;a^=b;
#define Pi acos(-1.0)
using namespace std;
double sum[MAXN];
int main(void){
	int T;
	scanf("%d", &T);
	while(T--) {
		int n, f;
		scanf("%d%d", &n, &f);
		double maxArea = 0.0;
		for(int i=0; i<n; ++i) {
			int r;
			scanf("%d", &r);
			sum[i] = Pi*r*r;
			maxArea = max(maxArea, sum[i]);
		}
		double L = 0.0;
		double R = maxArea;
		while(R-L > 1e-5) {
			double M = (R+L)/2.0;
			int pie = 0;
			for(int i=0; i<n; ++i) {
				pie += floor(sum[i]/M);
			}
			if(pie >= f+1) {
				L = M;
			} else R = M;
		}
		printf("%.5lf\n", L);
	} 

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值