hdu 4027 Can you answer these queries? 线段树

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 8067    Accepted Submission(s): 1832


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3308  2871  1542  3397  4046 
 


题意:对一个序列有2种操作,cmd=0时,将区间[ l , r ]的数开根号向下取整,cmd=1时,查询区间[ l , r ]的sum。

思路:维护区间最大值,若区间最大值为1时,1开根号还是1,不会影响查询的区间和。所以区间最大值为1时就无需跟新下面的结点了。

注意:查询的l , r可能存在l>r的情况,RE了好几发= =。 详见代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int MAXN=100000+100;
int n,m;
struct node
{
    int l,r;
    ll Max,sum;
}segtree[MAXN<<2];
void push_up(int rt)
{
    segtree[rt].Max=max(segtree[rt<<1].Max,segtree[rt<<1|1].Max);
    segtree[rt].sum=segtree[rt<<1].sum+segtree[rt<<1|1].sum;
}
void build(int rt,int l,int r)
{
    segtree[rt].Max=segtree[rt].sum=0;
    segtree[rt].l=l,segtree[rt].r=r;
    if(l==r)
    {
        scanf("%I64d",&segtree[rt].Max);
        segtree[rt].sum=segtree[rt].Max;
        return ;
    }
    int mid=(l+r)>>1;
    build(rt<<1,l,mid); build(rt<<1|1,mid+1,r);
    push_up(rt);
}
void update(int rt,int l,int r)
{
    if(segtree[rt].Max<=1)
        return ;
    if(segtree[rt].l==segtree[rt].r)
    {
        segtree[rt].Max=(ll)sqrt(1.0*segtree[rt].Max);
        segtree[rt].sum=segtree[rt].Max;
        return ;
    }
    int mid=(segtree[rt].l+segtree[rt].r)>>1;
    if(r<=mid)
        update(rt<<1,l,r);
    else if(l>mid)
        update(rt<<1|1,l,r);
    else
    {
        update(rt<<1,l,mid);
        update(rt<<1|1,mid+1,r);
    }
    push_up(rt);
}
ll query(int rt,int l,int r)
{
    if(segtree[rt].l==l && segtree[rt].r==r)
        return segtree[rt].sum;
    int mid=(segtree[rt].l+segtree[rt].r)>>1;
    if(r<=mid)
        return query(rt<<1,l,r);
    if(l>mid)
        return query(rt<<1|1,l,r);
    return query(rt<<1,l,mid)+query(rt<<1|1,mid+1,r);
}
int main()
{
    //freopen("text.txt","r",stdin);
    int kase=0;
    while(~scanf("%d",&n))
    {
        kase++;
        build(1,1,n);
        scanf("%d",&m);
        printf("Case #%d:\n",kase);
        while(m--)
        {
            int cmd,l,r;
            scanf("%d%d%d",&cmd,&l,&r);
            if(l>r)
                swap(l,r);
            if(cmd==0)
                update(1,l,r);
            if(cmd==1)
                printf("%I64d\n",query(1,l,r));
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值