PAT甲级真题及训练集(2)--1065. A+B and C (64bit) (20)

1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
/**
作者:一叶扁舟
时间:12:50 2017/6/17
思路:

*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>


int main(){
	int N;
	long long  a, b, c;
	scanf("%d",&N);
	char judge[2][6] = { "false", "true" };
	int flag = 0;
	for (int i = 0; i < N; i++){
		scanf("%lld%lld%lld",&a,&b,&c);
		long long  sum = a + b;
		if (a > 0 && b > 0 && sum < 0){//说明和正溢出了
			flag = 1;
		}
		else if (a < 0 && b < 0 && sum >= 0){//说明负溢出了,特别要注意sum也可能等于0
			flag = 0;
		}
		else if (sum > c){//未溢出,正常的加法
			flag = 1;
		}else{
			flag = 0;
		}
		printf("Case #%d: %s\n", i + 1,judge[flag]);
	
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值