PAT甲级真题及训练集(14)--1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

提交代

/**
作者:一叶扁舟
时间:17:41 2017/6/26
思路:就是将所有单位的货币钱转换成一种货币单位最小的值,然后使用加法最后再转
	注:原本都是用int的变量,但是在pat测试时发现总有一个测试不通过,因此后来改为long long
	结果通过了,说明了如果用int则有可能存在溢出

*/

#include <stdlib.h>
#include <string.h>
#include<iostream>
using namespace std;

int main(){
	long long pG, pS, pK;
	long long aG, aS, aK;
	long long rG, rS, rK;
	long long  allPK;
	long long  allAK;
	long long  rest;//总共多少钱

	scanf("%lld.%lld.%lld", &pG, &pS, &pK);
	scanf("%lld.%lld.%lld", &aG, &aS, &aK);

	//将钱都转成最小单位
	allPK = pG * 17 * 29 + pS * 29 + pK;
	allAK = aG * 17 * 29 + aS * 29 + aK;

	rest = allPK + allAK;
	rG = rest / (17 * 29);
	long long temp = rest % (17 * 29);
	rS = temp / 29;
	rK = temp % 29;
	//输出结果
	printf("%lld.%lld.%lld", rG, rS, rK);


	system("pause");
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值