PAT甲级真题及训练集(18)--1097. Deduplication on a Linked List (25)

1097. Deduplication on a Linked List (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

提交代


/**
作者:一叶扁舟
时间:21:37 2017/7/1
思路:
*/
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include<math.h>
using namespace std;
#define SIZE 100001
typedef struct SList{
	int address;//地址,其对应着数组的下标
	int data;//数据域
	int next;//下一个数据的地址,对应着数组的下标
	int order;//用来排序
}SList;

//将链表以递增的顺序排序
bool compe(SList a, SList b){
	return a.order < b.order;
}
int main(){
	SList sList[SIZE];
	int address, data, next;
	int N;//要输入的数据的长度
	int firstAddress;//链表开始的首地址jisuan
	int num[SIZE] = { 0 };//用来标识出现的次数
	SList removeResult[SIZE];
	int rmCount = 0;
	scanf("%d %d", &firstAddress, &N);
	//初始化是,排序都默认是最大的
	for (int i = 0; i < SIZE; i++){
		sList[i].order = SIZE;
	}

	//初始化静态数组和其下标是一样的
	//1.获取输入数据,地址对应着下标
	for (int i = 0; i < N; i++){
		scanf("%d %d %d", &address, &data, &next);
		sList[address].address = address;
		sList[address].data = data;
		sList[address].next = next;
	}
	//2.将链表串起来,过滤掉一些无效数据
	int i = firstAddress;//首地址
	int count = 0;
	while (i != -1){
		int temp = sList[i].data;
		temp = abs(temp);
		if (num[temp] == 0){//该数据第一次出现
			num[temp] = 1;
			sList[i].order = count;
			count++;
			i = sList[i].next;
		}else{//跳过当前链表,不做任何处理
			removeResult[rmCount].data = sList[i].data;
			removeResult[rmCount].address = sList[i].address;
			removeResult[rmCount].next = sList[i].next;
			rmCount++;
			i = sList[i].next;
		}

	}
	if (count == 0){//链表有效结点为0时,pat测试有这个判断
		printf("0 -1\n");
		return 0;
	}
	//2.排序(从小到大的将所有数据进行排序,有数据的都排在前面)
	sort(sList, sList + SIZE, compe);

	//输出
	for (int i = 0; i < count; i++){
		if (i == count - 1){//最后一个要单独处理,因为-1无法用五位数输出格式
			printf("%05d %d -1\n", sList[i].address, sList[i].data);
			break;
		}
		printf("%05d %d %05d\n", sList[i].address, sList[i].data, sList[i + 1].address);
	}
	//输出删除的结果
	for (int i = 0; i < rmCount; i++){
		if (i == rmCount - 1){
			printf("%05d %d -1\n", removeResult[i].address, removeResult[i].data);
		}else{
			printf("%05d %d %05d\n", removeResult[i].address, removeResult[i].data, removeResult[i + 1].address);
		}
	
	}
	system("pause");
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值