UVA725 Division【枚举】

  Division 
Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where
'$2 . That is,

abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.


Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).


Your output should be in the following general form:

xxxxx / xxxxx = N
xxxxx / xxxxx = N
.
.

In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62

0


Sample Output 

There are no solutions for 61.

79546 / 01283 = 62

94736 / 01528 = 62


题目大意:输入一个正整数N,要求从小到大的输出形如abcde / fghij = n的表达式。

要求a~f为数字0~9,且不能重复(前边可有0)。

思路:如果将a b c d e f g h i j全部遍历的话,复杂度是10!,没有必要,直接枚举

f g h i j,然后算出a b c d e,去判断是否存在重复数字即可。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int sum,num,N,j;
    int a,b,c,d,e;
    int f,g,h,l,m;
    int x[10],ok = 0;
    while(~scanf("%d",&N) && N)
    {
        if(ok == 0)
            ok = 1;
        else
            printf("\n");
        sum = 0;
        for(int i = 1234; i <= 98765; i++)
        {
            memset(x,0,sizeof(x));
            a = i%10,b = i/10%10,c = i/100%10,d = i/1000%10,e = i/10000%10;
            num = i*N;
            if(num>98765)
                break;
            f = num%10,g = num/10%10,h = num/100%10,l = num/1000%10,m = num/10000%10;
            x[a]++,x[b]++,x[c]++,x[d]++,x[e]++;
            x[f]++,x[g]++,x[h]++,x[l]++,x[m]++;
            for(j = 0; j <= 9; j++)
                if(x[j]>1)
                    break;
            if(j==10)
            {
                printf("%d%d%d%d%d / %d%d%d%d%d = %d\n",m,l,h,g,f,e,d,c,b,a,N);
                sum++;
            }
            else
                continue;
        }
        if(sum==0)
            printf("There are no solutions for %d.\n",N);
    }

    return 0;
}




  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值