枚举入门

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79. That is, abcde fghij = N where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero. Input Each line of the input file consists of a valid integer N. An input of zero is to terminate the program. Output Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator). Your output should be in the following general form: xxxxx / xxxxx = N xxxxx / xxxxx = N . .
In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line. Sample Input 61 62 0 Sample Output There are no solutions for 61.
79546 / 01283 = 62 94736 / 01528 = 62

解题思路
将除法改成乘法去解决,然后它至少是四位数即1234,最大是五位数,即98765,然后枚举这里面的数,就能得到m,然后判断这十个数是否不重复。。这里我不会判断啊。。就参考了大佬的博客。用while和数组判断,每次%10再/10来把那个数出现的次数存到数组里 然后判断数组的值加起来是否等于10``

小细节
在输出的时候每两个例子之间一个空行,也就是说最后输出的下面是没有空行的,还有就是,,除号前后和等号前后都有一个空格啊!!一开始每加空格 提交了好几次,,,

代码如下

#include<stdio.h>
#include<string.h>
int p(int m,int n)
{
	int a[10],sum=0,i;
	memset(a,0,sizeof(a));
	while(m!=0)
	{
		a[m%10]=1;
		m/=10;
	}
	if(n<10000)
	   a[0]=1;
	while(n!=0)
	{
		a[n%10]=1;
		n/=10;
	}
	for(i=0;i<10;i++)
	   sum+=a[i];
	if(sum==10)
	   return 1;
	return 0;
}
int main()
{
	int n,m,i,a[10],count,flag=0;
	while(~scanf("%d",&n)&&n)
	{
		count=0;
		if(flag)
		   printf("\n");
		flag++;
		for(i=1000;i<100000;i++)
		{
			m=n*i;
			if(m>=100000)
			    break;
		    if(p(m,i))
			{
				count++;
				printf("%05d / %05d = %d\n",m,i,n);
			}	

		}
		if(count==0)
		  printf("There are no solutions for %d.\n",n);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值