hdu1789 sdut2076 Doing Homework again(贪心)

Doing Homework again
Time Limit: 1000MS    Memory limit: 65536K

题目描述

 Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

输入

 The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

输出

 For each test case, you should output the smallest total reduced score, one line per test case.

示例输入

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

示例输出

0
3
5

 

题意:

 一天只能完成一个作业,每个作业有规定的完成时间和未完成要扣的分数,求扣分最小值

 

方法一:

先按时间排,时间相同的分高优先,剩余完不成的与以前完成的作业分数比较,如果分数较大则替换

#include<stdio.h>
#include<algorithm>
using namespace std;
struct ss
{
    int dead,sco,ok;
} work[1010];
int cmp(ss a,ss b)
{
    if(a.dead==b.dead) return a.sco>b.sco;
    return a.dead<b.dead;
}
int main()
{
    int t,n,i,j,sum,day,a,b;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d",&n);
            for(i=0; i<n; i++)
            {
                scanf("%d",&work[i].dead);
                work[i].ok=0;
            }
            for(i=0; i<n; i++)
            {
                scanf("%d",&work[i].sco);
            }
            sort(work,work+n,cmp);
            day=1;
            for(i=0; i<n; i++)
            {
                if(work[i].dead>=day)
                {
                    work[i].ok=1;
                    day++;
                }
            }
            for(i=0; i<n; i++)
            {
                if(work[i].ok==0)
                {
                    a=i;
                    b=work[i].sco;
                    for(j=0; j<i; j++)
                    {
                        if(work[j].ok==1&&work[j].sco<b)
                        {
                            a=j;
                            b=work[j].sco;
                        }
                    }
                    if(a!=i)
                    {
                        work[i].ok=1;
                        work[a].ok=0;
                    }
                }
            }
            sum=0;
            for(i=0; i<n; i++)
            {
                if(work[i].ok==0)
                {
                    sum+=work[i].sco;
                }
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}


 方法二:

从最后期限那天开始选择作业,一直选到第一天,手工模拟一下很容易理解

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct ss
{
    int dea,sco;
    bool don;
} s[1004];
bool cmp(ss a,ss b)
{
    if(a.dea==b.dea) return a.sco>b.sco;
    return a.dea>b.dea;
}
int main()
{
    int t,n,i,j,x,ans,mx;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            memset(s,0,sizeof(s));
            scanf("%d",&n);
            for(i=0; i<n; i++)
                scanf("%d",&s[i].dea);
            for(i=0; i<n; i++)
                scanf("%d",&s[i].sco);
            sort(s,s+n,cmp);
            for(i=s[0].dea; i>0; i--)//假如时光能倒流,我们从最后期限开始选择作业
            {
                for(mx=x=j=0; j<n; j++)
                {
                    if(s[j].dea<i)
                        break;
                    if(!s[j].don&&s[j].sco>mx)
                    {
                        mx=s[j].sco;
                        x=j;
                    }
                }
                s[x].don=1;
            }
            for(ans=i=0; i<n; i++)
                if(!s[i].don)
                    ans+=s[i].sco;
            printf("%d\n",ans);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值