hdu2117 Just a Numble

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2077    Accepted Submission(s): 970


Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
 

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
 

Output
For each line of input, your program should print a numble on a line,according to the above rules
 

Sample Input
  
  
4 2 5 7 123 123
 

Sample Output
  
  
5 0 8
 

模拟除法,刚开始还以为很麻烦呢,还找了循环节,循环节前有几位不循环,还有不是循环小数的,还有1。。。结果学长说一直算下去就行!!!
#include<stdio.h>
#include<string.h>
int s[100004];
int main()
{
	int n,m,a,i;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==1)
		{
			printf("0\n");
			continue;
		}
		memset(s,0,sizeof(s));
		a=1;
		for(i=1;i<=m;i++)
		{
			a*=10;
			while(a<n)
			{
				a*=10;
				s[i++]=0;
			}
			s[i]=a/n;
			a%=n;
			if(!a) break;
		}
		printf("%d\n",s[m]);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值