HDU-ACM2117

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2952    Accepted Submission(s): 1454


Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
 

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
 

Output
For each line of input, your program should print a numble on a line,according to the above rules
 

Sample Input
  
  
4 2 5 7 123 123
 

Sample Output
  
  
5 0 8

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        while (input.hasNext()){
            int n=input.nextInt();
            int m=input.nextInt();
            int x=1,i;
            int quotient=0,remainder;
            for (i=0;i<m+1;i++){
                quotient=0;
                quotient=x/n;
                remainder=x%n;
                if (quotient==0){
                    x*=10;
                }else {
                    x=remainder*10;
                }
                if (x==0){
                    break;
                }
            }
            if (i<m){
                quotient=0;
            }
            System.out.println(quotient);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值