ZOJ3498 Javabeans(找规律)

Javabeans

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

Each test case is a line of a positive integer 0 < n < 231.

Output

For each test case output the result in a single line.

Sample Input

4
1
2
3
4

Sample Output

1
2
2
3
 
题意:
    n个盒子,第i个盒子里有i个javabean,每天选一个整数x,将至少含有x个javabean的盒子里的javabean吃掉x个,问最少几天吃完?
 
思路:
    每天选择的x应为这一天一个盒子中javabean的最大数,这样每吃一次,最大个数就变为昨天的一半,这样天数的计算就可以用递推得到了,n扩大2倍,天数就加1。
 
#include<stdio.h>
int s[32];
int main()
{
    int t,n,i;
    for(i=1; i<32; i++)
        s[i]=1<<i-1;
    while(scanf("%d",&t)!=EOF)
        while(t--)
        {
            scanf("%d",&n);
            for(i=31; i>=1; i--)
                if(n>=s[i])
                {
                    printf("%d\n",i);
                    break;
                }
        }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值