2014西安赛区网络赛 5014 Number Sequence

 

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 214    Accepted Submission(s): 110
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 


给定n  数组a中保存0--n  n+1个数  每个数都不一样
数组b中同样存储这n+1个数 问 b数组中的数应该如何安排使得  ai^bi的和最大
暴力模拟  对每位取反  去异或  求最大值
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

#define eps 1e-8
#define op operator
#define MOD  10009
#define MAXN  100010

#define FOR(i,a,b)  for(int i=a;i<=b;i++)
#define FOV(i,a,b)  for(int i=a;i>=b;i--)
#define REP(i,a,b)  for(int i=a;i<b;i++)
#define REV(i,a,b)  for(int i=a-1;i>=b;i--)
#define MEM(a,x)    memset(a,x,sizeof a)
#define ll __int64
using namespace std;

ll n;
ll a[MAXN],b[MAXN];

ll dfs(ll x)
{
    if(x<=0)  return 0;
    ll y=x;
    ll m=1;
    while(y>1)
    {
        y/=2;
        m*=2;
    }
//    cout<<m<<endl;
    ll res=0;
    ll q=m-1;
    for(ll i=m;i<=x;i++)
    {
        res+=(i^q)*2;
        b[i]=q; b[q]=i;
        q--;
    }
    res+=dfs(q);
    return res;
}



int main()
{
//freopen("ceshi.txt","r",stdin);

    while(scanf("%I64d",&n)!=EOF)
    {
        for(ll i=0;i<=n;i++)
            scanf("%I64d",&a[i]);
        MEM(b,0);
//        int res;
        printf("%I64d\n",dfs(n));
        printf("%I64d",b[a[0]]);
        for(ll i=1;i<=n;i++)
            printf(" %I64d",b[a[i]]);
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值