hnu 13003 Meeting Room Arrangement

Meeting Room Arrangement
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 14, Accepted users: 14
Problem 13003 : No special judgement
Problem description

Faculty of Engineering of PSU has a large meeting room for faculty staff to organize events andmeetings. The use of the meeting room must be reserved in advance. Since the meeting room isavailable in 10 hours per day and there may be several events that want to use the meeting room, thebest usage policy is to maximize the number of events in day.
Suppose that the meeting room is available from time 0 to 10 (10 hours). Given the list ofstart time and finish time of each candidate event, you are to write a program to select the events thatfit in the meeting room (i.e. their times do not overlap) and give the maximum number of events in aday.


Input

The first line is a positive integer n (1<=n<=100) which determines the number of days (testcases). Each test case consists of the time of the candidate events (less than 20 events). Each eventtime includes 2 integers which are start time(s) and finish time(f), 0<=s<=9, 1<=f<=10 and s

Output

For each test case, print out the maximum number of events that can be arranged in themeeting room.


Sample Input
3
0 6
5 7
8 9
5 9
1 2
3 4
0 5
0 0
6 10
5 6
0 3
0 5
3 5
4 5
0 0
1 5
3 9
0 0
Sample Output
4
4
1

其实就是简单的会议室安排问题 但是当时做的时候还卡了一会儿  想想也是有点气。。

就是将会议的结束时间           从小到大排序

每次都是选取当前结束最早的会议        将该会议的开始时间与之前的结束时间进行比较

如果可以就将该会议加进去

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

#define eps 1e-8
#define op operator
#define MOD  10009
#define MAXN  100100

#define FOR(i,a,b)  for(int i=a;i<=b;i++)
#define FOV(i,a,b)  for(int i=a;i>=b;i--)
#define REP(i,a,b)  for(int i=a;i<b;i++)
#define REV(i,a,b)  for(int i=a-1;i>=b;i--)
#define MEM(a,x)    memset(a,x,sizeof a)
#define ll __int64

using namespace std;

struct node
{
    int st,ft;
    bool operator<(const node p)const
    {
        return ft<p.ft;
    }
};
node no[50];


int main()
{
//freopen("ceshi.txt","r",stdin);
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        int st,ft;
        int cnt=0;
        while(1)
        {
            scanf("%d%d",&st,&ft);
            if(st==0&&ft==0)
                break;
            no[cnt].st=st; no[cnt].ft=ft;
            cnt++;
        }
        sort(no,no+cnt);
//    for(int i=0;i<cnt;i++)
//        cout<<no[i].st<<"   "<<no[i].ft<<endl;
        int mx=0;
        int th=0;
        int e=0;
        for(int i=0;i<cnt;i++)
        {
            if(no[i].st>=e)
            {
                mx++;
                e=no[i].ft;
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值