UVAlive 6606 Meeting Room Arrangement

Faculty of Engineering of PSU has a large meeting room for faculty staff to organize events and meetings. The use of the meeting room must be reserved in advance. Since the meeting room is available in 10 hours per day and there may be several events that want to use the meeting room, the best usage policy is to maximize the number of events in day. Suppose that the meeting room is available from time 0 to 10 (10 hours). Given the list of start time and finish time of each candidate event, you are to write a program to select the events that fit in the meeting room (i.e. their times do not overlap) and give the maximum number of events in a day.
Input The first line is a positive integer n (1 ≤ n ≤ 100) which determines the number of days (test cases). Each test case consists of the time of the candidate events (less than 20 events). Each event time includes 2 integers which are start time(s) and finish time(f), 0 ≤ s ≤ 9, 1 ≤ f ≤ 10 and s < f. The line containing ‘0 0’ indicates the end of each test case. Note that an event must use at least 1 hour.
Output
For each test case, print out the maximum number of events that can be arranged in the meeting room.
Sample Input

3

0 6

5 7

8 9

5 9

1 2

3 4

0 5

0 0

6 10

5 6

0 3

0 5

3 5

4 5

0 0

1 5

3 9

0 0

Sample Output

4

4

1

题意:在0~10的时间内问最多能放几条新闻;

思路:贪心即可;

下面附上我的代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		pair<int,int> itv[25];
		for(int i=0;i<25;i++){
			itv[i].first=itv[i].second=0;
		}
		int x,y;
		int p=0;
		while(scanf("%d%d",&x,&y)){
			if(x==0&&y==0) break;
			itv[p].first=y;
			itv[p].second=x;
			p++;
		}
		sort(itv,itv+p);
		
		int ans=0,t=0;
		for(int i=0;i<p;i++){
			if(t<=itv[i].second){
				ans++;
				t=itv[i].first;
			}
		}
		printf("%d\n",ans);
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值