Poj 1419Graph Coloring(搜索|| 最大团)

13 篇文章 0 订阅
2 篇文章 0 订阅

Language:
Graph Coloring
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4369 Accepted: 1979 Special Judge

Description

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black. 


 
Figure 1: An optimal graph with three black nodes 

Input

The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

Output

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5

Source



给图中的点染色  相邻的两个点不能都为黑色 求出最多的黑色顶点的个数及顶点的编号


最常规的方法就是搜索

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

void read(int &x)
{
    char ch;
    x=0;
    while(ch=getchar(),ch!=' '&&ch!='\n')
    {
        x=x*10+ch-'0';
    }
}

int n,m;
int edge[110][110];
int ans;
int black[110];
int col[110];

void color(int num,int cnt)
{
    if(num==(n+1))
    {
        if(cnt>ans)
        {
            ans=cnt;
            int x=0;
            for(int i=1;i<=n;i++)
                if(col[i]) black[x++]=i;

        }
        return;
    }
    bool flag=1;
    for(int i=1;i<=n;i++)
    {
        if(edge[num][i]&&col[i])//如果相邻且已经染为黑色
            flag=0;
    }
    if(flag)//相邻都为白色
    {
        col[num]=1;
        color(num+1,cnt+1);
        col[num]=0;
    }
    color(num+1,cnt);
}

int main()
{
    //fread;
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        scanf("%d%d",&n,&m);
        MEM(edge,0);
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            edge[u][v]=edge[v][u]=1;
        }
        ans=0;
        MEM(col,0);//初始化都为白色
        color(1,0);
        printf("%d\n",ans);
        for(int i=0;i<ans;i++)
        {
            if(i) printf(" ");
            printf("%d",black[i]);
        }
        puts("");
    }
    return 0;
}

搜索的相对来说 速度比较慢

这题还可以转化为最大团

将图转化为补图  然后求最大团

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

void read(int &x)
{
    char ch;
    x=0;
    while(ch=getchar(),ch!=' '&&ch!='\n')
    {
        x=x*10+ch-'0';
    }
}
const int MAXN=110;
bool flag[MAXN],a[MAXN][MAXN];
int ans,cnt[MAXN],group[MAXN],vis[MAXN];
int n,m;

bool dfs(int u,int pos)
{
    for(int i=u+1;i<=n;i++)
    {
        if(cnt[i]+pos<=ans)  return 0;
        if(a[u][i])
        {
            //与目前团中元素比较
            int j;
            for(j=0;j<pos;j++)
                if(!a[i][vis[j]])
                    break;
            if(j==pos)// 若为空,则皆与 i 相邻,则此时将i加入到 最大团中
            {
                vis[pos]=i;
                if(dfs(i,pos+1))
                    return 1;
            }
        }
    }
    if(pos>ans)
    {
        for(int i=0;i<pos;i++)
            group[i]=vis[i];// 最大团 元素
        ans=pos;
        return 1;
    }
    return 0;
}

void maxclique()
{
    ans=-1;
    for(int i=n;i>0;i--)
    {
        vis[0]=i;
        dfs(i,1);
        cnt[i]=ans;
    }
}

int main()
{
    //fread;
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        scanf("%d%d",&n,&m);
        MEM(a,0);
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            a[u][v]=a[v][u]=1;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i==j)  a[i][j]=0;
                else a[i][j]^=1;//构造补图
            }
        }
        maxclique();
        if(ans<0) ans=0;
        printf("%d\n",ans);
        for(int i=0;i<ans;i++)
        {
            if(i) printf(" ");
            printf("%d",group[i]);
        }
        puts("");
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值