csu 1601 War(并查集)

1601: War

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 82   Solved: 24
[ Submit][ Status][ Web Board]

Description

AME decided to destroy CH’s country. In CH’ country, There are N villages, which are numbered from 1 to N. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. To defend the country from the attack of AME, CH has decided to build some roads between some villages. Let us say that two villages belong to the same garrison area if they are connected.
Now AME has already worked out the overall plan including which road and in which order would be attacked and destroyed. CH wants to know the number of garrison areas in his country after each of AME’s attack.

Input

The first line contains two integers N and M — the number of villages and roads, (2 ≤ N ≤ 100000; 1 ≤ M ≤ 100000). Each of the next M lines contains two different integers u, v (1<=u, v<=N)—which means there is a road between u and v. The next line contains an integer Q which denotes the quantity of roads AME wants to destroy (1 ≤ Q ≤ M). The last line contains a series of numbers each of which denoting a road as its order of appearance — different integers separated by spaces.

Output

Output Q integers — the number of garrison areas in CH’s country after each of AME's attack. Each pair of numbers are separated by a single space.

Sample Input

3 1
1 2
1
1
4 4
1 2
2 3
1 3
3 4
3
2 4 3

Sample Output

3
1 2 3

n个点 m条无向边 依次删除某条边 求删除这条边之后 有多少个连通分量

使用并查集来记录 这些点是否处于同一个联通分量 

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
#include<stack>
#include<map>
using namespace std;
#define REP(x, y) for(int x = 0; x < y; x++)
#define DWN(x, y) for(int x = y-1; x > -1; x--)
const int maxn=100010;
int num;
int fa[maxn];
 
int find_fa(int x)
{
    if(fa[x] == -1) return x;
    else return fa[x] = find_fa(fa[x]);
}
 
void Union(int a, int b)
{
    int ba = find_fa(a);
    int bb=find_fa(b);
    if(ba!=bb)
    {
        fa[ba]=bb;
        num--;
    }
}
 
int ea[maxn],eb[maxn];
int t[maxn];
int vis[maxn];
 
int main()
{
//    freopen("B.in", "r", stdin);
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        num=n;
        memset(vis,0,sizeof vis);
        memset(fa,-1,sizeof fa);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&ea[i],&eb[i]);
        }
        int q;
        scanf("%d",&q);
        int cnt=0;
        for(int i=0;i<q;i++)
        {
            int z;
            scanf("%d",&z);
            vis[z]=1; t[cnt++]=z;
        }
//        cout<<"cnt "<<cnt<<endl;
        for(int i=1;i<=m;i++)
        {
            if(!vis[i]) Union(ea[i],eb[i]);
        }
        stack<int> sta;
        for(int i=q-1;i>=0;i--)
        {
            int z=t[i];
            sta.push(num);
            Union(ea[z],eb[z]);
//            cout<<"num "<<num<<endl;
        }
        while(!sta.empty())
        {
            int z=sta.top(); sta.pop();
            printf("%d",z);
            if(!sta.empty()) printf(" ");
            else puts("");
        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值