poj 1681 Painter's Problem(高斯消元 开关问题 )

Language:
Painter's Problem
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4834 Accepted: 2346

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow. 

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15



格子中涂了黄色和白色 现在要用刷子去刷 使得格子都变为黄色的 

刷一个格子时 这个格子的上下左右的颜色也都会变  求要刷的最少次数

用高斯消元之后 需要枚举自由变元 找出解中1个数最少的那个

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 300
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char c = getchar();
    while (c < '0' || c > '9') c = getchar();
    int x = 0;
    while (c >= '0' && c <= '9') {
        x = x * 10 + c - '0';
        c = getchar();
    }
    return x;
}

void Print(int a)
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}

int equ,var;//equ个方程 var个变元 增广矩阵行数为equ 列数为var+1 分别为0到var
int a[MAXN][MAXN];//增广矩阵
int x[MAXN];//解集
int free_x[MAXN];//存储自由变元(多解枚举自由变元可以使用)
int free_num;//自由变元的个数
int n;

void init()
{
    MEM(a,0); MEM(x,0);
    equ=n*n; var=n*n;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            int t=i*n+j;
            a[t][t]=1;
            if(i>0) a[(i-1)*n+j][t]=1;
            if(i<n-1) a[(i+1)*n+j][t]=1;
            if(j>0) a[i*n+j-1][t]=1;
            if(j<n-1) a[i*n+j+1][t]=1;
        }
}
//返回值为-1表示无解 为0是唯一解 否则返回自由变元个数
int Gauss()
{
    int max_r,col,k;
    free_num=0;
    for(k=0,col=0;k<equ&&col<var;k++,col++)
    {
        max_r=k;
        for(int i=k+1;i<equ;i++)
        {
            if(abs(a[i][col])>abs(a[max_r][col]))
                max_r=i;
        }
        if(a[max_r][col]==0)
        {
            k--;
            free_x[free_num++]=col;//这个是自由变元
            continue;
        }
        if(max_r!=k)
        {
            for(int j=col;j<var+1;j++)
                swap(a[k][j],a[max_r][j]);
        }
        for(int i=k+1;i<equ;i++)
        {
            if(a[i][col]!=0)
            {
                for(int j=col;j<var+1;j++)
                    a[i][j]^=a[k][j];
            }
        }
    }
    for(int i=k;i<equ;i++)
        if(a[i][col]!=0)
            return -1;//无解
    if(k<var) return var-k;//自由变元个数
    //唯一解  回带
    for(int i=var-1;i>=0;i--)
    {
        x[i]=a[i][var];
        for(int j=i+1;j<var;j++)
            x[i]^=(a[i][j]&&x[j]);
    }
    return 0;
}

void solve()
{
    int t=Gauss();
    if(t==-1)
    {
        puts("inf");
    }
    else if(t==0)
    {
        int ans=0;
        for(int i=0;i<n*n;i++)
            ans+=x[i];
        printf("%d\n",ans);
    }
    else
    {
        int ans=INF;
        int tot=(1<<t);
        for(int i=0;i<tot;i++)
        {
            int cnt=0;
            for(int j=0;j<t;j++)
            {
                if(i&(1<<j))
                {
                    x[free_x[j]]=1;
                    cnt++;
                }
                else x[free_x[j]]=0;
            }
            for(int j=var-t-1;j>=0;j--)
            {
                int idx;
                for(idx=j;idx<var;idx++)
                    if(a[j][idx])
                        break;
                x[idx]=a[j][var];
                for(int l=idx+1;l<var;l++)
                    if(a[j][l])
                        x[idx]^=x[l];
                cnt+=x[idx];
            }
            ans=min(cnt,ans);
        }
        printf("%d\n",ans);
    }
}

char ch[20][20];

int main()
{
//    fread;
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        scanf("%d",&n);
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%s",ch[i]);
            for(int j=0;j<n;j++)
            {
                if(ch[i][j]=='y')
                    a[i*n+j][n*n]=0;
                else a[i*n+j][n*n]=1;
            }
        }
        solve();
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值