hdu 2795 Billboard(线段树 单点更新)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16198    Accepted Submission(s): 6852


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 



公告栏高度为h 宽度为w 贴公告 每次都从上面开始选位置  都从最左侧开始贴 不能覆盖

问每次贴的公告贴在第几行 

线段树  用叶子节点模拟每行的情况 如果这行所剩的长度比需要的长度大 就可以贴

只上的每个节点来记录左右子树的最大值 从而可以判断这里能不能再张贴了。。

代码写起来不困难 主要还是如何抽象为线段树吧。。。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 200010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

struct node
{
    int l,r;
    int num;
};
node no[MAXN*4];
int h,w,n;

void build(int l,int r,int k)
{
    no[k].l=l;
    no[k].r=r;
    no[k].num=w;
    if(l==r)
        return;
    int mid=(l+r)/2;
    build(l,mid,k*2);
    build(mid+1,r,k*2+1);
}
int ans;
int Query(int num,int k)
{
    if(no[k].l==no[k].r)
    {
        no[k].num-=num;
        return no[k].l;
    }
    int res;
    if(no[k*2].num>=num)
        res=Query(num,k*2);
    else if(no[k*2+1].num>=num)
        res=Query(num,k*2+1);
    no[k].num=max(no[k*2].num,no[k*2+1].num);
    return res;

}

int main()
{
//    fread;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        int num=min(h,MAXN);
        build(1,num,1);
        while(n--)
        {
            int a;
            scanf("%d",&a);
//            cout<<"a  "<<a<<"  num "<<no[1].num<<endl;
            if(a>no[1].num)
                puts("-1");
            else
            {
                ans=Query(a,1);
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值