poj 2019 Cornfields(二维RMQ)

Language:
Cornfields
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6033 Accepted: 2964

Description

FJ has decided to grow his own corn hybrid in order to help the cows make the best possible milk. To that end, he's looking to build the cornfield on the flattest piece of land he can find. 

FJ has, at great expense, surveyed his square farm of N x N hectares (1 <= N <= 250). Each hectare has an integer elevation (0 <= elevation <= 250) associated with it. 

FJ will present your program with the elevations and a set of K (1 <= K <= 100,000) queries of the form "in this B x B submatrix, what is the maximum and minimum elevation?". The integer B (1 <= B <= N) is the size of one edge of the square cornfield and is a constant for every inquiry. Help FJ find the best place to put his cornfield. 

Input

* Line 1: Three space-separated integers: N, B, and K. 

* Lines 2..N+1: Each line contains N space-separated integers. Line 2 represents row 1; line 3 represents row 2, etc. The first integer on each line represents column 1; the second integer represents column 2; etc. 

* Lines N+2..N+K+1: Each line contains two space-separated integers representing a query. The first integer is the top row of the query; the second integer is the left column of the query. The integers are in the range 1..N-B+1. 

Output

* Lines 1..K: A single integer per line representing the difference between the max and the min in each query. 

Sample Input

5 3 1
5 1 2 6 3
1 3 5 2 7
7 2 4 6 1
9 9 8 6 5
0 6 9 3 9
1 2

Sample Output

5



裸的二维RMQ 求矩阵中最大值与最小值的差

直接套板子就可以了

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;
int n,b,k;

int dmax[310][310][9][9],dmin[310][310][9][9];
int mm[310];
int val[310][310];

void RMQ_init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            dmax[i][j][0][0]=dmin[i][j][0][0]=val[i][j];
//    bug;
    for(int ii=0;ii<=mm[n];ii++)
        for(int jj=0;jj<=mm[n];jj++)
            if(ii+jj)
                for(int i=1;i+(1<<ii)-1<=n;i++)
                    for(int j=1;j+(1<<jj)-1<=n;j++)
    {
        if(ii)
        {
            dmax[i][j][ii][jj]=max(dmax[i][j][ii-1][jj],dmax[i+(1<<(ii-1))][j][ii-1][jj]);
            dmin[i][j][ii][jj]=min(dmin[i][j][ii-1][jj],dmin[i+(1<<(ii-1))][j][ii-1][jj]);
        }
        else
        {
            dmax[i][j][ii][jj]=max(dmax[i][j][ii][jj-1],dmax[i][j+(1<<(jj-1))][ii][jj-1]);
            dmin[i][j][ii][jj]=min(dmin[i][j][ii][jj-1],dmin[i][j+(1<<(jj-1))][ii][jj-1]);
        }
    }
//    bug;
}

int rmqmax(int x1,int y1,int x2,int y2)
{
    int k1=mm[x2-x1+1];
    int k2=mm[y2-y1+1];
    x2=x2-(1<<k1)+1;
    y2=y2-(1<<k2)+1;
    return max(max(dmax[x1][y1][k1][k2],dmax[x1][y2][k1][k2]),max(dmax[x2][y1][k1][k2],dmax[x2][y2][k1][k2]));
}

int rmqmin(int x1,int y1,int x2,int y2)
{
    int k1=mm[x2-x1+1];
    int k2=mm[y2-y1+1];
    x2=x2-(1<<k1)+1;
    y2=y2-(1<<k2)+1;
    return min(min(dmin[x1][y1][k1][k2],dmin[x1][y2][k1][k2]),min(dmin[x2][y1][k1][k2],dmin[x2][y2][k1][k2]));
}

int main()
{
//    fread;
    mm[0]=-1;
    for(int i=1;i<=310;i++)
        mm[i]=((i&(i-1))==0)?mm[i-1]+1:mm[i-1];
    while(scanf("%d%d%d",&n,&b,&k)!=EOF)
    {
//        bug;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&val[i][j]);
        RMQ_init();
        while(k--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",rmqmax(x,y,x+b-1,y+b-1)-rmqmin(x,y,x+b-1,y+b-1));
        }
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值