hdu 3183 A Magic Lamp(RMQ)

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2400    Accepted Submission(s): 959


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 



输入一个数字 删去这个数字中的m个字符 还保证剩下数字的顺序 问能组成的最小数字是什么

如果数字的总长度为len 删除m个字符还剩len-m个 则在前len-m个字符中一定有一个字符是剩下字符中的第一个

在剩下字符数一定的情况下 要保证每位上的数字尽可能小就可以了 所以要在0-len-l-m中寻找第一个字符的位置pos

找到之后 下一个字符的寻找位置从 pos+1开始 到len-2-m。。。。。

直到找到所有的数字

因为本题的过程中要找到区间最小字符的位置 所以定义一种求最小的值的方法 比较两个位置的字符大小 返回小字符的那个位置


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 1010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int a[MAXN],dp[MAXN][30];
char ch[1010];
int n;
char ans[1010];

int Min(int x,int y)
{
    if(ch[x]<=ch[y])
        return x;
    return y;
}

void RMQ_init()
{
    for(int i=0;i<n;i++)
        dp[i][0]=i;
    for(int j=1;(1<<j)<=n;j++)
        for(int i=0;i+(1<<j)-1<n;i++)
            dp[i][j]=Min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}

int RMQ(int l,int r)
{
    int k=0;
    while((1<<(k+1))<=r-l+1) k++;
    return Min(dp[l][k],dp[r-(1<<k)+1][k]);
}

int main()
{
//    fread;
    while(scanf("%s",ch)!=EOF)
    {
        int m;
        scanf("%d",&m);
        int len=strlen(ch);
        n=len;
        RMQ_init();
        int pos=0;
        int num=0;
        m=len-m;
        while(m--)
        {
           pos=RMQ(pos,len-m-1);
           ans[num++]=ch[pos++];
        }
        int j;
        for(j=0;j<num;j++)
            if(ans[j]!='0')//去除先导0
                break;
        if(j==num)
            puts("0");
        else
        {
            for(;j<num;j++)
                printf("%c",ans[j]);
            puts("");
        }

    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值