大数取余

(a b) ((a c) (b c)) c
(a b) ((a c) (b c)) c
10000位大的数字可以分开算:
比如:
m=123
123 (1*10 2)*10 3
m%n 123%n (((1%n 10%n 2%n)%n 10%n) 3%n)%n

string m;
long n, d;
int i;
cin >> >> n;

d=0;
for (i 0; m.size(); i++)
{
   ((d 10) m[i] '0') n;
   // d*10是不超过10*n的,m[i] '0'是不超过10的,除非10*n或者n+9溢出,否则整个计算过程都不会溢出
}
cout << << endl;


 

描述

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

输入

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

输出

For each test case, you have to ouput the result of A mod B.

样例输入


2 3
12 7
152455856554521 3250

样例输出


2
5
1521

 

#include <iostream>
using namespace std;
int main()
{
 string m;
 long n, d;
 int i;
 while (cin >> m >> n)
 {
     d = 0;
  for (i = 0; i < m.size(); i++)
  {
   d = ((d * 10) % n + m[i] - '0') % n;
  }
  cout << d << endl;
 }
 return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值