(a
(a
10000位大的数字可以分开算:
比如:
m=123
123
m%n
string
long
int
cin
d=0;
for
{
}
cout
描述
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
输入
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
输出
For each test case, you have to ouput the result of A mod B.
样例输入
2 3
12 7
152455856554521 3250
样例输出
2
5
1521
#include <iostream>
using namespace std;
int main()
{
string m;
long n, d;
int i;
while (cin >> m >> n)
{
d = 0;
for (i = 0; i < m.size(); i++)
{
d = ((d * 10) % n + m[i] - '0') % n;
}
cout << d << endl;
}
return 0;
}