Magnificent Meatballs

Sam and Ella run a catering service. They like to put on a show when serving meatballs to guests seated at round tables. They march out of the kitchen with pots of meatballs and start serving adjacent guests. Ella goes counterclockwise and Sam goes clockwise, until they both plop down their last meatball, at the same time, again at adjacent guests. This impressive routine can only be accomplished if they can divide the table into two sections, each having the same number of meatballs. You are to write a program to assist them.

At these catering events, each table seats 2 ≤ N ≤ 30 guests. Each guest orders at least one and at most nine meatballs. Each place at the table is numbered from 1 to N, with the host at position 1 and the host's spouse at position N. Sam always serves the host first then proceeds to serve guests in increasing order. Ella serves the spouse first, then serves guests in decreasing order. The figures illustrate the first two example input cases.

Two dinner tables

Input consists of one or more test cases. Each test case contains the number of guests N followed by meatballs ordered by each guest, from guest 1 to guest N. The end of the input is a line with a single zero.

For each table, output a single line with the ending positions for Sam and Ella, or the sentence indicating an equal partitioning isn't possible. Use the exact formatting shown below.

Sample Input
5 9 4 2 8 3
5 3 9 4 2 8
6 1 2 1 2 1 2
6 1 2 1 2 1 1
0
Sample Output
Sam stops at position 2 and Ella stops at position 3.
No equal partitioning.
No equal partitioning.
Sam stops at position 3 and Ella stops at position 4.



题意:(输入)每个样例一行:输入n(表示后面有n个数),在输入的n个数a1-aN表示每个客人点的肉丸个数
(计算)这n个客人围城一圈 问是否存在一点i使得sum(a1-to-ai)==sum(ai+1-to-aN);
(输出)如果存在这样的i输出i和i+1表示Sam和Ella的位置 不然输出No equal partitioning.
分析:计算所有肉球的总和,如果不能被2整除 则不可能存在 如果存在从a1累加如果找到ai时有等于sum的一半并且i<n就输出i和i+1 不然就输出找不到,,,,,,----------->
 
 
源代码:
 
#include<iostream> 
using namespace std;
 int main() 
{     
      int num[30],T;     
      while(cin>>T&&T!=0)     
      {          
               int sum=0;          
               int location=0;          
               for(int i=0;i<T;++i)          
               {              
                     cin>>num[i];               
                     sum+=num[i];                         //求和          
                }          
                if(sum%2!=0)cout<<"No equal partitioning."<<endl;   //为奇数则直接输出         
                else          
                {              
                      int sum1=0;              
                      bool flag=false;             
                      for(int i=0;i<T-1;++i)              
                      {                   
                             sum1+=num[i];                   
                             if(sum1==sum/2){location=i+1;flag=true;break;}  //若存在则将位置存放在location中,将flag置为true                                    else if(sum1>sum/2)break;                       //当sum1大于sum/2时,证明不存在             
                      }              
                      if(flag)cout<<"Sam stops at position "<<location<<" and Ella stops at position "<<location+1<<"."<<endl;                             else    cout<<"No equal partitioning."<<endl;         
                }    
           }    
      return 0; 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值