TJU Change

After Shawn sees the following picture, he decides to give up his career in IT and turn to sell fruits. Since Shawn is a lazy guy, he doesn’t like to do any extra work. When he starts selling fruits, he finds that he always needs to take changes for customers. He wants you to write a program to give the least number of changes. Shawn is also a strange guy, because he takes changes by 6,5,3,1.

Input

The first line of input is an integer T which indicates the sum of test case. Each of the following T lines contains an integer n(1≤n≤105), which is the total money Shawn need to give to the customer.

Output

For each test case, output "Case i: Result" in one line where i is the case number and Result is the least number of changes Shawn need to give customer.

Sample Input

3
4
10
19

Sample output

	
Case 1: 2
Case 2: 2
Case 3: 4

Hint

Case 1: 4=3+1
Case 2: 10=5+5
Case 3: 19=6+6+6+1

题意概述:找零钱问题,老生常谈了。题目中有4中面值的零钱,分别是:6,5,3,1 .要用找给客人的零钱数量最少。

解题思路:本来以为要用到动态规划,那块没学好,所以就偷了个懒,找了一下规律。11以下数量很容易得到,大于11是,用剩余面额减掉最大的,即6.小于等于11是,只需加上相应的数量即可。

源代码:

#include<iostream>
using namespace std;


int main()
{
    int T,N;
    cin>>T;
    for(int i=1;i<=T;++i)
    {
        int min=0;
        cin>>N;
        while(N>11)
        {
            ++min;
            N-=6;
        }
        if(7<=N&&N<=11)min+=2;
        else if(5<=N&&N<=6)++min;
        else if(N==4)min+=2;
        else if(N==3||N==1)++min;
        else if(N==2)min+=2;
        cout<<"Case "<<i<<": "<<min<<endl; 
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值