Just the Facts

The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

 N       N! 
 0       1 
 1       1 
 2       2 
 3       6 
 4      24 
 5     120 
10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 ≤ N ≤ 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input Format

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Required Output Format

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain " -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input

1
2
26
125
3125
9999

Sample Output

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


题意概述:给定一个N,求出N!,从右向左输出第一位不为零的数字。


解题思路:看到题目,我第一种想法就是:这个题一定有简便方法,而且要注意数的范围。如果不存在简单方法,那么数的范围将是一个非常麻烦的问题。大家可以想象一下,任何数乘0,结果还是0. 所以对每一次的预案算结果都把最后的0去掉。同时考虑到int数据能表示10位的整数,为了不超出范围,每次都让去掉末尾0的结果对100000取余,这样既可以保证结果不超出范围,又能得到想要的结果。


源代码:


#include<cstdio>  
int main()  
{  
   int n,s,i;  
   while(scanf("%d",&n)==1)  
  {  
     for(i=1,s=1;i<=n;i++)  
     {  
        s*=i;  
        while(s%10==0)  //循环取出s结果后面的0
           s/=10; 
        //一定要至少保留后五位非零位(五位以上要注意int型溢出,因此取五位最佳),
        //因为后五位非零位的进位(极限情况3125,即5^5)会影响到最后的非零位   
        s=s%100000;  
     }  
     printf("%5d -> %d\n",n,s%10);  
  }  
  return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值