Speed Limit

Time Limit: 1.0 Seconds   Memory Limit: 65536K
Total Runs: 2602   Accepted Runs: 1751



Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

For example, if their log shows

Speed in miles per hour
Total elapsed time in hours
20
2
30
6
10
7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 = 170 miles. Note that the total elapsed time is always since the beginning of the trip, not since the previous entry in their log.

Input: The input consists of one or more data sets. Each set starts with a line containing an integer n, 1 ≤ n ≤ 10,  followed by n pairs of values, one pair per line. The first value in a pair, s, is the speed in miles per hour and the second value, t, is the total elapsed time. Both s and t are integers, 1 ≤ s ≤ 90 and 1 ≤ t ≤ 12.  The values for are always in strictly increasing order. A value of -1 for n signals the end of the input.

Output: For each input set, print the distance driven, followed by a space, followed by the word "miles". 

Example input:Example output:
3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1
170 miles
180 miles
90 miles

题意概述:很简答的一道题,题意就不多说了。


解题思路:刚开始的思路是用map做关联式数组,但仔细一想后觉得更本不需要。对于每一次输入,只需要知道该时间段内汽车行驶速度以及以该速度行驶的时间。数度是输入的,不难确定;至于时间长度,只需要记录下上一个时刻点,有此次输入的时间点减去上一个时刻点即可,也不难。


源代码:


#include<iostream>
using namespace std;
int main()
{
    int n,speed,hour,time,distance;//speed代表速度,hour代表上一个时间点,time代表下一个时间点 
    while(cin>>n&&n!=-1)  //这个条件太蛋疼了,原来以为n必须大于0,结果错了 
    {
         hour=0;
         distance=0;
         for(int i=0;i<n;++i)
         {
                 cin>>speed>>time;
                 distance+=speed*(time-hour);
                 hour=time;
         }
         cout<<distance<<" miles"<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值