linux 修改yum源

Linux 专栏收录该内容
1 篇文章 0 订阅

因为redhat自带的yum源是收费的,是需要注册的。所以,我们常常需要更换yum源来使用yum命令,因为,yum可以很好的解决包的依赖问题。下面,直接进入正题,修改yum源。

1,查看本地yum安装包并卸载自带的yum包

1)查看系统自带的yum包

       rpm -qa | grep yum

2)卸载自带的yum包

rpm -qa | grep yum | xargs rpm -e --nodeps

3)卸载Python-urlgrabber

rpm -qa | grep Python-urlgrabber | xargs rpm -e --nodeps

2,下载yum安装包

yum包来源:

(1)http://mirrors.163.com/centos/

(2)http://vault.centos.org/

(3)https://mirrors.edge.kernel.org/centos/

(4)https://opsx.alibaba.com/mirror

根据系统版本,选择下面红色字体对应的包并用wget命令下载。

例如:

#  wget  http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-3.4.3-161.el7.centos.noarch.rpm     

#  wget  http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.31-50.el7.noarch.rpm     

#  wget  http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-metadata-parser-1.1.4-10.el7.x86_64.rpm 

#  wget http://vault.centos.org/7.3.1611/os/x86_64/Packages/yum-utils-1.1.31-40.el7.noarch.rpm

3,安装yum包

这三个包需要同时安装:

rpm -ivh yum-3.4.3-161.el7.centos.noarch.rpm yum-plugin-fastestmirror-1.1.31-50.el7.noarch.rpm yum-metadata-parser-1.1.4-10.el7.x86_64.rpm yum-utils-1.1.31-40.el7.noarch.rpm

注意,若因为系统不一样,可能出现的问题也不一样。若出现缺少依赖包的情况,可根据具体报出的缺失依赖包名在使用的yum源下查找下载并安装。

4,下载repo配置文件并配置(CentOS-Base.repo)

下载base版:wget http://mirrors.163.com/.help/CentOS7-Base-163.repo

在yum源中找到对应的配置文件,将其下载到/etc/yum.repos.d/路径下。

并修改其配置的yum源为自己使用的yum源即可

5,测试修改结果(更新yum缓存)

1)清楚yum缓存: yum clean all

2)更新yum缓存: yum makecache

3)查看repo仓库列表:yum  repolist 

 

6,执行yum update --skip-broken

这一步很重要,只有执行完这一步之后,yum才能算正常使用。不然在安装其他rpm包的时候,总会报依赖关系错误或找不到依赖包等问题。

-------------------------------------------------------------------

至此,yum源修改完成

  • 0
    点赞
  • 0
    评论
  • 2
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值