BUCT OJ 2264: The Unsolvable Problem

题目描述

   
   
There are many unsolvable problem in the world.It could be about one or about zero.But this time it is about bigger number. Given an integer n(2 <= n <= 10 9).We should find a pair of positive integer a, b so that a + b = n and [a, b] is as large as possible. [a, b] denote the least common multiplier of a, b.

输入

The first line contains integer T(1<= T<= 10000),denote the number of the test cases.
For each test cases,the first line contains an integer n.

输出

For each test cases,print the maximum [a,b] in a line.

样例输入

3
2
3
4

样例输出

1
2
3
上代码~
#include <stdio.h> 
#define ll long long 
int main() 
{ 
    ll n, n_case; 
    scanf("%lld", &n_case); 
    while(n_case--){ 
        scanf("%lld", &n); 
        if(n==2) 
        printf("1\n"); 
        else
        { 
            if(n%2) 
            printf("%lld\n", (n/2)*(n-n/2)); 
            else
            { 
                if((n/2)%2==0) 
                printf("%lld\n", (n/2-1)*(n/2+1)); 
                else
                printf("%lld\n", (n/2-2)*(n/2+2)); 
            } 
        } 
    } 
    return 0; 
} 
  
/************************************************************** 
    Problem: 2264 
    User: 2012014425 
    Language: C 
    Result: 正确 
    Time:12 ms 
    Memory:768 kb 
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值