【PAT】【Advanced Level】1049. Counting Ones (30)

1049. Counting Ones (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5
原题链接:

https://www.patest.cn/contests/pat-a-practise/1049

https://www.nowcoder.com/pat/5/problem/4088

思路:

占坑写题解。。。

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<cstdlib>
using namespace std;


int main()
{
	string a;
	cin>>a;
	int re=0;
	long long sum=0;
	long long te=1;
	for (int i=a.length()-1;i>=0;i--)
	{
		if (a[i]-'0'==0) 
		{
			re+=( atoi(a.substr(0,i).c_str())*te );
		}
		else if(a[i]-'0'==1) 
		{
			re+=( atoi(a.substr(0,i).c_str())*te + sum +1);
		}
		else
		{
			re+=( (atoi(a.substr(0,i).c_str())+1)*te );
		}
		//cout<<re<<endl;
		sum+=te*(a[i]-'0');
		te*=10;
	}
	cout<<re;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值