【PAT】【Advanced Level】1097. Deduplication on a Linked List (25)

1097. Deduplication on a Linked List (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
原题链接:

https://www.patest.cn/contests/pat-a-practise/1097

思路:

输入,map映射地址、下标

然后根据map从起始地址开始串成链表,同时检查绝对值情况

CODE:

#include<iostream>
#include<cstdio>
#include<vector>
#include<map>
#include<cmath>
#define N 100010


using namespace std;

typedef struct S
{
	int ad;
	int va;
	int nx;	
};

S st[N];

map<int,int> ma1;

map<int,int> ma2;

vector<S> com;
vector<S> oth;



int main()
{
	int n;
	int bg;
	scanf("%d %d",&bg,&n);
	//cout<<bg<<" "<<n<<endl;
	for (int i=0;i<n;i++)
	{
		scanf("%d %d %d",&st[i].ad,&st[i].va,&st[i].nx);
		ma1[st[i].ad]=i;
	}
	while (bg!=-1)
	{
		if (ma2[abs(st[ma1[bg]].va)]==0)
		{
			ma2[abs(st[ma1[bg]].va)]=1;
			com.push_back(st[ma1[bg]]);
		}
		else
		{
			oth.push_back(st[ma1[bg]]);
		}
		bg=st[ma1[bg]].nx;
	}
	
	for (int i=0;i<com.size();i++)
	{	
		printf("%05d %d ",com[i].ad,com[i].va);
		if (i!=com.size()-1)
		{
			printf("%05d\n",com[i+1].ad);
		}
		else
			printf("-1\n");
	}
	for (int i=0;i<oth.size();i++)
	{	
		printf("%05d %d ",oth[i].ad,oth[i].va);
		if (i!=oth.size()-1)
		{
			printf("%05d\n",oth[i+1].ad);
		}
		else
			printf("-1\n");
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用 JavaScript 编写的杀死幽灵游戏(附源代码) 杀死鬼魂游戏是使用 Vanilla JavaScript、CSS 和 HTML 画布开发的简单项目。这款游戏很有趣。玩家必须触摸/杀死游荡的鬼魂才能得分。您必须将鼠标悬停在鬼魂上 - 尽量得分。鬼魂在眨眼间不断从一个地方移动到另一个地方。您必须在 1 分钟内尽可能多地杀死鬼魂。 游戏制作 这个游戏项目只是用 HTML 画布、CSS 和 JavaScript 编写的。说到这个游戏的特点,用户必须触摸/杀死游荡的幽灵才能得分。游戏会根据你杀死的幽灵数量来记录你的总分。你必须将鼠标悬停在幽灵上——尽量得分。你必须在 1 分钟内尽可能多地杀死幽灵。游戏还会显示最高排名分数,如果你成功击败它,该分数会在游戏结束屏幕上更新。 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox。要玩游戏,首先,单击 index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值