1097. Deduplication on a Linked List (25)

102 篇文章 0 订阅
37 篇文章 0 订阅

1097. Deduplication on a Linked List (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
输入
root头地址   总地址N个
接着N行  地址  放的值  下一个地址
       ……
输出
outpulist的头地址  值  下一个地址
            ……
removelist的头地址  值 下一个地址
            ……
 PS:其中当没有下一个地址的时候,(NULL)next=-1;
这一题求的是以头地址为开头的链表,最先出现的地址里面的值第一次出现放在outpulist里面如果与这个值的绝对值一样的第二次出现,那么在removelist里面

 评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月19日 19:20答案正确251097C++ (g++ 4.7.2)2693752datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确2107613/13
1答案正确210763/3
2答案正确110762/2
3答案正确26936764/4
4答案正确26437523/3
#include<iostream>   
#include<vector>    
#include<iomanip>
#define Addrmax 100000
#define valuemx 10000
using namespace std; 
void readln(vector<pair<int, int>>*list, int N)
{
  int address, key, next;
  while (N--)
  {
    cin >> address >> key >> next;
    (*list)[address] = make_pair(key, next);
  }
}
void Display(vector<pair<int, int>>*outlist)
{
  int len = (*outlist).size();
  if (len > 0)
  {
    int index;
    len--;
    for (index = 0; index < len; index++)
      cout << setw(5) << setfill('0') << (*outlist)[index].first << " " << (*outlist)[index].second << " "
      << setw(5) << setfill('0') << (*outlist)[index + 1].first << endl; 
    cout << setw(5) << setfill('0') << (*outlist)[len].first << " " << (*outlist)[index].second << " -1"
       << endl;
  } 

}
int main()
{
  int N,root; 
  vector<pair<int, int>>list(Addrmax);
  vector<bool>turnonce(valuemx, false);
  vector<pair<int, int>>outputlist;
  vector<pair<int, int>>removelist;
  cin >> root >> N;
  readln(&list, N);
  while (root != -1)
  {
    N = (list[root].first > 0) ? list[root].first :-list[root].first;
    if (!turnonce[N])
    {
      outputlist.push_back(make_pair(root, list[root].first));
      turnonce[N] = true;
    }
    else 
      removelist.push_back(make_pair(root, list[root].first)); 
    root = list[root].second;
  }
  Display(&outputlist);
  Display(&removelist);
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值