【PAT】【Advanced Level】1102. Invert a Binary Tree (25)

14 篇文章 0 订阅
8 篇文章 0 订阅

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
原题链接:

https://www.patest.cn/contests/pat-a-practise/1102

思路:

输入、建树。

遍历的时候,先右子树,再根节点、再左子树。同时记录层数、遍历次序

然后针对层序排序输出

最后输出中序序列

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdlib>
#include<vector>
#include<algorithm>
#define N 11
using namespace std;
typedef struct S
{
	int bh;
	int flo;
	int tra;
	int ls;
	int rs;
};
S t[N];
bool fl[N];
vector<S> ft;
vector<S> it;
void dfs(int n,int ff)
{
	if (t[n].rs!=-1)
	{
		dfs(t[n].rs,ff+1);
	}
	t[n].tra=it.size();
	t[n].flo=ff;
	ft.push_back(t[n]);
	it.push_back(t[n]);
	if (t[n].ls!=-1)
	{
		dfs(t[n].ls,ff+1);
	}
}
bool cmp(S a, S b)
{
	if (a.flo==b.flo)
	{
		return a.tra<b.tra;
	}
	else
	{
		return a.flo<b.flo;
	}
}
int main()
{
	memset(fl,0,sizeof(fl));
	int n;
	cin>>n;
	for (int i=0;i<n;i++)
	{
		string a,b;
		cin>>a>>b;
		t[i].bh=i;
		if (a=="-")
			t[i].ls=-1;
		else
		{
			int temp=atoi(a.c_str());
			t[i].ls=temp;
			fl[temp]=1;
		}
		if (b=="-")
			t[i].rs=-1;
		else
		{
			int temp=atoi(b.c_str());
			t[i].rs=temp;
			fl[temp]=1;
		}
	}
	int root;
	for (int i=0;i<n;i++)
		if (fl[i]==0)
		{
			root=i;
			break;
		}
	dfs(root,0);
	sort(ft.begin(),ft.end(),cmp);
	for (int i=0;i<n;i++)
	{
		if (i!=0) cout<<" ";
		cout<<ft[i].bh;
	}
	cout<<endl;
	for (int i=0;i<n;i++)
	{
		if (i!=0) cout<<" ";
		cout<<it[i].bh;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值