1020 Tree Traversals (25分)--PAT甲级真题

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:分别给出二叉树的后续遍历序列和中序遍历序列,要求输出该二叉树的层次遍历序列。

分析:由后续和中序序列可以唯一确认一棵二叉树;建树之后,后对该二叉树再进行一次层次遍历;

#include<iostream> 
#include<queue> 
using namespace std; 
struct Node{
	Node* lchild;
	Node* rchild;
	int d;
}Tree[31]; 
int loc; 
Node* create(){
	Tree[loc].lchild = Tree[loc].rchild = NULL;
	return &Tree[loc++];
} 
int arr1[31], arr2[31]; 
void LevelOrder(Node* T){
	queue<Node*> Q;
	Q.push(T);
	int flag = 0;
	while (!Q.empty()){
		Node* tmp = Q.front();
		Q.pop();
		if (flag == 0)
			flag = 1;
		else
			printf(" ");
		printf("%d", tmp->d); 
		if (tmp->lchild != NULL)
			Q.push(tmp->lchild);
		if (tmp->rchild != NULL)
			Q.push(tmp->rchild);
	}
} 
Node* build(int s1, int e1, int s2, int e2){
	Node *ret = create();
	ret->d = arr1[e1];
	int rootindex;
	for (int i = s2; i <= e2; i++){
		if (arr2[i] == arr1[e1]){
			rootindex = i;
			break;
		}
	} 
	if (rootindex != s2) //若左子树不为空
		ret->lchild = build(s1, s1 + (rootindex - 1 - s2), s2, rootindex - 1);  
	if (rootindex != e2) //若右子树不为空 
		ret->rchild = build(s1 + (rootindex - 1 - s2) + 1, e1 - 1, rootindex + 1, e2); 
	return ret;
} 
int main(){
	int N;
	scanf("%d", &N);
	loc = 0;
	for (int i = 0; i < N; i++)
		scanf("%d", &arr1[i]);
	for (int i = 0; i < N; i++)
		scanf("%d", &arr2[i]);
	Node* T = build(0, N - 1, 0, N - 1);
	LevelOrder(T); 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值