1117. Eddington Number(25)
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.
Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.
Output Specification:
For each case, print in a line the Eddington number for these N days.
Sample Input:10 6 7 6 9 3 10 8 2 7 8Sample Output:
6
https://www.patest.cn/contests/pat-a-practise/1117
思路:
排序,从前向后找,找到下标小于等于值为止
坑点:
注意,题意要求公里数大于天数,所以找的时候结束条件为下标小于等于值
CODE:
#include<iostream>
#include<algorithm>
#define N 100010
using namespace std;
// more than / no less than
int num[N];
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n;
cin>>n;
for (int i=1;i<=n;i++)
{
cin>>num[i];
}
sort(num+1,num+n+1,cmp);
int res=0;
for (int i=1;i<=n;i++)
{
if (num[i]<=i) // < / <=
{
cout<<i-1;
break;
}
else
{
if (i==n) cout<<n;
}
}
return 0;
}