【PAT】【Advanced Level】1126. Eulerian Path (25)

11 篇文章 0 订阅
9 篇文章 0 订阅

1126. Eulerian Path (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
原题链接:

https://www.patest.cn/contests/pat-a-practise/1126

思路:

统计节点的度数

判断是否是连通图

判断是否有欧拉回路

CODE:

#include<iostream>
#include<vector>
#include<cstring>
#define N 510
using namespace std;
vector<int>  ed[N];
bool flag[N];
void dfs(int n)
{
	flag[n]=1;
	for (int i=0;i<ed[n].size();i++)
	{
		if (flag[ed[n][i]]==0)
		{
			dfs(ed[n][i]);
		}
	}
	return;
}
int main()
{
	int n,m;
	cin>>n>>m;
	for (int i=0;i<m;i++)
	{
		int a,b;
		cin>>a>>b;	
		ed[a].push_back(b);
		ed[b].push_back(a);
	}
	int sum=0;
	for (int i=1;i<=n;i++)
	{
		if (i!=1) cout<<" ";
		int ss=ed[i].size();
		cout<<ss;
		if (ss%2==1) sum++;
	}
	int con=0;
	memset(flag,0,sizeof(flag));
	for (int i=1;i<=n;i++)
	{
		if (flag[i]==0)
		{
			con++;
			dfs(i);
		}
	}
	if (con>1)
	{
		cout<<endl<<"Non-Eulerian"<<endl;
	}
	else
	{
		if (sum==0) 
		{
			cout<<endl<<"Eulerian"<<endl;
		}
		else if (sum==2)
		{
			cout<<endl<<"Semi-Eulerian"<<endl;
		}
		else
		{
			cout<<endl<<"Non-Eulerian"<<endl;
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值